HDU/HDOJ 2855 2009 Multi-University Training Contest 5 - Host by NUDT 矩阵二分幂

 

Fibonacci Check-up

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 615    Accepted Submission(s): 333


Problem Description
Every ALPC has his own alpc-number just like alpc12, alpc55, alpc62 etc.
As more and more fresh man join us. How to number them? And how to avoid their alpc-number conflicted?
Of course, we can number them one by one, but that’s too bored! So ALPCs use another method called Fibonacci Check-up in spite of collision.

First you should multiply all digit of your studying number to get a number n (maybe huge).
Then use Fibonacci Check-up!
Fibonacci sequence is well-known to everyone. People define Fibonacci sequence as follows: F(0) = 0, F(1) = 1. F(n) = F(n-1) + F(n-2), n>=2. It’s easy for us to calculate F(n) mod m.
But in this method we make the problem has more challenge. We calculate the formula , is the combination number. The answer mod m (the total number of alpc team members) is just your alpc-number.
 

Input
First line is the testcase T.
Following T lines, each line is two integers n, m ( 0<= n <= 10^9, 1 <= m <= 30000 )
 

Output
Output the alpc-number.
 

Sample Input
  
  
2 1 30000 2 30000
 

Sample Output
  
  
1 3
 

Source
 

 

有一个公式:

C(N,1)F1+C(N,2)F2+C(N,3)F3+...+C(N,N)FN=F(2N)

证明方法我有点忘了,大致是利用那个比内公式去推

n=0和1最好特判一下

我的代码:

#include<stdio.h>
#include<algorithm>
#include<string.h>

using namespace std;

struct mart{
	int mat[3][3];
};
int mod;
mart kk;

mart multi(mart a,mart b){
	mart c;
	int i,j,k;
	for(i=1;i<=2;i++)
		for(j=1;j<=2;j++)
		{
			c.mat[i][j]=0;
			for(k=1;k<=2;k++)
				c.mat[i][j]=(c.mat[i][j]%mod+(a.mat[i][k]%mod)*(b.mat[k][j]%mod)%mod)%mod;
		}
	return c;
}

mart power(int k){
	mart p,q;
	int i,j;
	for(i=1;i<=2;i++)
		for(j=1;j<=2;j++)
		{
			p.mat[i][j]=kk.mat[i][j];
			if(i==j)
				q.mat[i][j]=1;
			else
				q.mat[i][j]=0;
		}
	if(k==0)
		return q;
	while(k!=1)
	{
		if(k&1)
		{
			k--;
			q=multi(p,q);
		}
		else
		{
			k=k>>1;
			p=multi(p,p);
		}
	}
	p=multi(p,q);
	return p;
}

int main(){
	int n,m,tt;
	scanf("%d",&tt);
	mart xx;
	while(tt--)
	{
		scanf("%d%d",&n,&m);
		if(n==0)
		{
			printf("0\n");
			continue;
		}
		if(n==1)
		{
			printf("%d\n",1%m);
			continue;
		}
		mod=m;
		kk.mat[1][1]=0;
		kk.mat[1][2]=1;
		kk.mat[2][1]=1;
		kk.mat[2][2]=1;
		xx=power(2*n-1);
		printf("%d\n",(xx.mat[1][1]+xx.mat[1][2])%mod);
	}
	return 0;
}



 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值