HDU 3488 2010多校联合6 图论

 

Tour

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 725    Accepted Submission(s): 363


Problem Description
In the kingdom of Henryy, there are N (2 <= N <= 200) cities, with M (M <= 30000) one-way roads connecting them. You are lucky enough to have a chance to have a tour in the kingdom. The route should be designed as: The route should contain one or more loops. (A loop is a route like: A->B->……->P->A.)
Every city should be just in one route.
A loop should have at least two cities. In one route, each city should be visited just once. (The only exception is that the first and the last city should be the same and this city is visited twice.)
The total distance the N roads you have chosen should be minimized.
 

Input
An integer T in the first line indicates the number of the test cases.
In each test case, the first line contains two integers N and M, indicating the number of the cities and the one-way roads. Then M lines followed, each line has three integers U, V and W (0 < W <= 10000), indicating that there is a road from U to V, with the distance of W.
It is guaranteed that at least one valid arrangement of the tour is existed.
A blank line is followed after each test case.
 

Output
For each test case, output a line with exactly one integer, which is the minimum total distance.
 

Sample Input
  
  
1 6 9 1 2 5 2 3 5 3 1 10 3 4 12 4 1 8 4 6 11 5 4 7 5 6 9 6 5 4
 

Sample Output
  
  
42
 

Source
 
刚开始看题表示完全木有思路。
后来看到别人用匹配。然后想了下,觉得有道理,就写了下,还好,1Y。
不过个人感觉还是没有领悟到精髓所在。。恩
先把代码贴出来,在仔细想想。恩
 
我的代码:
#include<stdio.h>
#include<string.h>
#define inf 99999999

int map[205][205];
int lx[205],ly[205];
bool x[205],y[205];
int link[205];
int n;

bool dfs(int u)
{
	int i;
	x[u]=true;
	for(i=1;i<=n;i++)
	{
		if(lx[u]+ly[i]==map[u][i]&&!y[i])
		{
			y[i]=true;
			if(link[i]==-1||dfs(link[i]))
			{
				link[i]=u;
				return true;
			}
		}
	}
	return false;
}

int main()
{
	int i,t,j,m;
	int a,b,l,k;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
				map[i][j]=-inf;
		for(i=1;i<=m;i++)
		{
			scanf("%d%d%d",&a,&b,&l);
			if(map[a][b]<-l)
				map[a][b]=-l;
		}
		memset(x,0,sizeof(x));
		memset(y,0,sizeof(y));
		memset(link,-1,sizeof(link));
		for(i=0;i<205;i++)
			lx[i]=inf;
		memset(ly,0,sizeof(ly));
		for(k=1;k<=n;k++)
		{
			while(1)
			{
				memset(x,0,sizeof(x));
				memset(y,0,sizeof(y));
				if(dfs(k))
					break;
				int d=inf;
				for(i=1;i<=n;i++)
					if(x[i])
						for(j=1;j<=n;j++)
							if(!y[j]&&lx[i]+ly[j]-map[i][j]<d)
								d=lx[i]+ly[j]-map[i][j];
				for(i=1;i<=n;i++)
					if(x[i])
						lx[i]=lx[i]-d;
				for(i=1;i<=n;i++)
					if(y[i])
						ly[i]=ly[i]+d;
			}
		}
		int ans=0;
		for(i=1;i<=n;i++)
			ans=ans+map[link[i]][i];
		printf("%d\n",-ans);
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值