POJ-1386 play on words(并查集+欧拉回路)

POJ-1386 play on words(并查集+欧拉回路)

Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us.

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door.

Input The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list.
Output Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times.
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.".
Sample Input
3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok
Sample Output
The door cannot be opened.
Ordering is possible.
The door cannot be opened.
#include<iostream>  
#include<cstdio>
#include<cstring>  
#define MAX 50  
using namespace std;  
int out[MAX],in[MAX],flag[MAX],p[MAX],father[MAX];        
int find(int x)
{
    if(x==father[x])
    return x;
    return find(father[x]);
}
void Union(int x,int y)
{
    int xn=find(x);
    int yn=find(y);
    if(xn!=yn)
    father[yn]=xn;
}  
int main()  
{  
    int i,t,n,cnt1,cnt2,begin,end;  
    char str[1100];  
    scanf("%d",&t);
    while(t--)  
    {  
        for(i=1;i<=26;i++)  
        father[i]=i;     //对26个字母进行初始化,1,2...26分别表示26个英文字母。  
        memset(in,0,sizeof(in));  
        memset(out,0,sizeof(out));  
        memset(flag,0,sizeof(flag));  
        scanf("%d",&n);
        while(n--)
        {  
            scanf("%s",str);  
            begin=str[0]-96;     //只考虑首尾,因为只有首尾有用。
            end=str[strlen(str)-1]-96;  
            Union(begin,end);     //将每个单词的首尾合并,头插向尾。
            in[end]++;       
            out[begin]++;        //这里真的很有意思,将首尾都放入图中考虑,如mouse,m-->e.m与e连通。
            flag[begin]=flag[end]=1;  //标记该字母已存在    acm malform mouse  a-->m-->m-->m-->m-->e
        }  
            cnt1=0;  
            for(i=1;i<=26;i++)  
            {  
                if(flag[i]&&father[i]==i)  
                cnt1++;  //统计根的个数,计算连通分支个数  
            }  
            if(cnt1>1)  //非连通图,直接输出  
            {  
                printf("The door cannot be opened.\n");
                continue;  //continue很重要
            }  
            cnt2=0;  
            for(i=1;i<=26;i++)  
            {  
                if(flag[i]&&in[i]!=out[i])  //计算存在字母的入度及出度不相等的节点数  
                    p[cnt2++]=i;  //定下欧拉通路的起终点
            }  
            if(cnt2==0)  //有向图中,所有点出度等于入度的节点,是欧拉回路 。
            {  
                printf("Ordering is possible.\n");  
                continue;  
            }  
            if(cnt2==2 && ((out[p[0]]-in[p[0]]==1&& in[p[1]]-out[p[1]]==1)   //入度与出度不相等的节点个数为2  
            || (out[p[1]]-in[p[1]]==1 && in[p[0]]-out[p[0]]==1)) )          //且起点出度减入度等于1或者终点入度减出度等于1,则是欧拉回路  
            {                                                               //或是因为起终点不确定。
                printf("Ordering is possible.\n");
                continue;  
            }  
                printf("The door cannot be opened.\n");  
        }  
        return 0;  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值