POJ-3140 Contestants Division(树型DP)

POJ-3140 Contestants Division(深搜)

 

In the new ACM-ICPC Regional Contest, a special monitoring and submitting system will be set up, and students will be able to compete at their own universities. However there’s one problem. Due to the high cost of the new judging system, the organizing committee can only afford to set the system up such that there will be only one way to transfer information from one university to another without passing the same university twice. The contestants will be divided into two connected regions, and the difference between the total numbers of students from two regions should be minimized. Can you help the juries to find the minimum difference?

Input

There are multiple test cases in the input file. Each test case starts with two integers N and M, (1 ≤ N ≤ 100000, 1 ≤ M ≤ 1000000), the number of universities and the number of direct communication line set up by the committee, respectively. Universities are numbered from 1 to N. The next line has N integers, the Kth integer is equal to the number of students in university numbered K. The number of students in any university does not exceed 100000000. Each of the following M lines has two integers s, t, and describes a communication line connecting university s and university t. All communication lines of this new system are bidirectional.

N = 0, M = 0 indicates the end of input and should not be processed by your program.

Output

For every test case, output one integer, the minimum absolute difference of students between two regions in the format as indicated in the sample output.

Sample Input

7 6
1 1 1 1 1 1 1
1 2
2 7
3 7
4 6
6 2
5 7
0 0

Sample Output

Case 1: 1
// 给你一棵树,问你删去一条边,形成的两棵子树的节点权值之差最小是多少。
#include<cstdio>  
#include<cstring>  
#include<iostream>  
#include<cmath>  
#include<algorithm>  
#include<vector>  
using namespace std;    
#define  MAX 100000 
int a[MAX+10];  
long long dp[MAX+10];  
vector<int> si[MAX+10];  //邻接表结构
long long minn,sum;  
long long absll(long long  x)  
{  
    return x>=0?x:-x;    //感觉数大的时候就用long long fabs是给double的,所以long long 要自己给函数 
}  
void dfs(int x,int fa)  
{       
        int i,y;
        dp[x]=a[x];    //dp[i]这个结点与他相邻并在他下面的结点和
        for(i=0;i<si[x].size();i++)  
        {  
            y=si[x][i];  
            if(y==fa)  
            continue;  
            dfs(y,x);  
            dp[x]+=dp[y];  
        }   
        minn=min(absll(sum-2*dp[x]),minn);  //(sum-dp[x])-dp[x];
} 
int main()  
{  
    int x,y,i;
    int n,m;
    int casen=1;  
    while(scanf("%d%d",&n,&m),n||m)  
{  
    for(i=1;i<=n;i++ )
    si[i].clear();   
    sum=0;  
    for(i=1;i<=n;i++)  
    {  
     scanf("%d",&a[i]);  
     sum+=a[i];  
    }  
    minn=sum;  
    for(i=0;i<m;i++)  
    {  
      scanf("%d%d",&x,&y);  
      si[x].push_back(y);  
      si[y].push_back(x);//双向边操作    
    }  
     dfs(1,-1);  
     printf("Case %d: %lld\n",casen++,minn);  
}   
       return 0;  
}  

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值