Contestants Division
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9909 Accepted: 2821
Description
In the new ACM-ICPC Regional Contest, a special monitoring and submitting system will be set up, and students will be able to compete at their own universities. However there’s one problem. Due to the high cost of the new judging system, the organizing committee can only afford to set the system up such that there will be only one way to transfer information from one university to another without passing the same university twice. The contestants will be divided into two connected regions, and the difference between the total numbers of students from two regions should be minimized. Can you help the juries to find the minimum difference?
Input
There are multiple test cases in the input file. Each test case starts with two integers N and M, (1 ≤ N ≤ 100000, 1 ≤ M ≤ 1000000), the number of universities and the number of direct communication line set up by the committee, respectively. Universities are numbered from 1 to N. The next line has N integers, the Kth integer is equal to the number of students in university numbered K. The number of students in any university does not exceed 100000000. Each of the following M lines has two integers s, t, and describes a communication line connecting university s and university t. All communication lines of this new system are bidirectional.
N = 0, M = 0 indicates the end of input and should not be processed by your program.
Output
For every test case, output one integer, the minimum absolute difference of students between two regions in the format as indicated in the sample output.
Sample Input
7 6
1 1 1 1 1 1 1
1 2
2 7
3 7
4 6
6 2
5 7
0 0
Sample Output
Case 1: 1
Source
Shanghai 2006
/*
2017/3/11
time: 485MS
题意:有一棵有n个节点的树,问你删除哪些节点后,使剩下的子树中节点数最大的值最小?
分析:(这是之前POJ 1741 tree这一题的一个子问题)
题目不难,先我们求出去掉每个节点后的最大值,然后找出其中的最小值,最后遍历一遍就可
在找出删除每个节点后的最大值,我们用dfs_node()首先求出以每个节点为根的子树的节点数目nodes[i]
然后删除i节点后的最大值就等于:以他每个孩子节点为根的子树的节点数目的最大值,和n - nodes[i] 中的大者
关于上面的问题我们直接dfs一遍更新即可
*/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
using namespace std;
const int maxn = 50010;
struct edge
{
int v,next;
}edges[2*maxn];
int head[maxn],e,n;
int nodes[maxn],maxnum[maxn];
void addedges(int u,int v)
{
edges[e].v = v;
edges[e].next = head[u];
head[u] = e++;
}
void dfs_subnode(int u,int f)
{
nodes[u] = 1;
for(int i=head[u];i!=-1;i=edges[i].next)
{
int v = edges[i].v;
if(v == f) continue;
dfs_subnode(v,u);
nodes[u] += nodes[v];
}
}
void dfs_up(int u,int f)
{
maxnum[u] = n - nodes[u];
for(int i=head[u];i!=-1;i=edges[i].next)
{
int v = edges[i].v;
if(v == f) continue;
if(maxnum[u] < nodes[v]) maxnum[u] = nodes[v];
dfs_up(v,u);
}
}
int main()
{
int u,v;
while(scanf("%d",&n)!=EOF)
{
memset(head,-1,sizeof(head));
e = 0;
for(int i=0;i<n-1;i++)
{
scanf("%d%d",&u,&v);
addedges(u,v);
addedges(v,u);
}
dfs_subnode(1,0);
dfs_up(1,0);
int minans = maxn;
for(int i=1;i<=n;i++) if(minans > maxnum[i])
minans = maxnum[i];
int t = 0;
for(int i=1;i<=n;i++) if(maxnum[i] == minans)
{
t++;
if(t == 1) printf("%d",i);
else printf(" %d",i);
}
printf("\n");
}
return 0;
}