HDU-1114 Piggy-Bank(完全背包)

Piggy-Bank

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

 

 

Problem Description

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

 

 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.

 

 

Output

Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".

 

 

Sample Input

 

310 11021 130 5010 11021 150 301 6210 320 4

 

Sample Output

 

The minimum amount of money in the piggy-bank is 60.The minimum amount of money in the piggy-bank is 100.This is impossible.

 

 

Source

Central Europe 1999

 

 

Recommend

Eddy   |   We have carefully selected several similar problems for you:  2191 1203 1059 1074 1024 

 

完全背包(CompletePack): 有N种物品和一个容量为V的背包,每种物品都有无限件可用。第i种物品的费用是c[i],价值是w[i]。求解将哪些物品装入背包可使这些物品的费用总和不超过背包容量,且价值总和最大。

完全背包两维

第一维:物品种类数

第二维:背包容量

dp是以背包容量的维度

#include <iostream>
#include <cstdio>
#define INF 0x3f3f3f3f
using namespace std;
#define MAXN 10100
int dp[MAXN];
int main()
{
   int t;
   int E,F;
   int i,j;
   scanf("%d",&t);
   while(t--)
   {
       scanf("%d%d",&E,&F);
       int N;
       scanf("%d",&N);
       for(i=1;i<=N;i++)
       {
             int P,W;
             //dp[i]表示重量为i的硬币的最小总价值
             dp[0]=0;
             for(i=1;i<=F-E;i++)   //F-E是总重量的
             dp[i]=INF;
             for(i=1;i<=N;i++)
            {
              scanf("%d%d",&P,&W);
              for(j=W;j<=F-E;j++)
              dp[j]=min(dp[j],dp[j-W]+P); //j从小到大的变化,体现了无限取的完全背包原则
            }                             //只有j是W的倍数才会加上。
       }
       if(dp[F-E]==INF)    //dp[F-E]算出的就是最大值。
       printf("This is impossible.\n");
       else
       printf("The minimum amount of money in the piggy-bank is %d.\n",dp[F-E]);
   }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值