POJ-2348 Euclid's Game (博弈论)

Euclid's Game

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10550 Accepted: 4295

Description

Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7): 

         25 7

         11 7

          4 7

          4 3

          1 3

          1 0


an Stan wins.

Input

The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.

Output

For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.

Sample Input

34 12
15 24
0 0

Sample Output

Stan wins
Ollie wins

Source

Waterloo local 2002.09.28

 

#include <cstdio>
#include <iostream>
using namespace std;
int main()
{
    int a,b;
    while(scanf("%d%d",&a,&b),a!=0||b!=0)
    {
          int flag=1;
          while(1)
          {
              if(a>b)
              swap(a,b); //默认b是较大数
              //如果b是a的倍数时必胜
              if(b%a==0)
              break;
              if(b-a>a) //b-a>a一定可以构造b-ax<a;通过b-(a-1)x或b-ax构造必败态,则b-a>a这种情况一定是必胜态
              break;
              //剩下的就是b-a<a的情况
              //只能不断在必败态与必胜态中转换
              //b-a的状态为必败态,则当前状态为必胜态
              //b-a的状态为必胜态,则当前状态为必败态
               b-=a;
               flag=!flag;
               //为什么初始的flag设为1呢?
               //那是因为b-a<a的情况只能靠b%a==0出来,而这个状态就是必胜态,所以初始状态为必胜态。
               //其他两种情况flag为1,显然
           }
           if(flag)
           printf("Stan wins\n");
           else
           printf("Ollie wins\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值