AMD处理器&VM8.0 完美安装Mac OS X 10.6.0 并成功升级至10.6.8 成功安装 Xcode 4.2

    由于项目开发ios,需装ios系统,于是在网上搜到各种教程,安装了N次,一次次的失败让我差点绝望想转身开发Andriod,而一想到苹果那优美的界面,幻想自己用笔记本玩mac系统,开发自己的程序,就一而再再而三的不断尝试新的方法,阅遍了无数教程之后,终于安装成功了,这次是真成功了,不再在开机运行几分钟之后出现乱码,黑屏,显示:system configuration and what you were doing at the time that thekernel panic occured.We apologize for inconvenience.(后接一大版CPUDebug信息)”。

    不管你信不信,反正我是信了,AMD,真TM的不能装10.7 lion AMD处理器至多安装10.6,如果你的处理器是2Duoi3i5i7或者xeon的则可以安装10.7。是否支持VT技术似乎不重要- -。

   好啦,开始安装了:一、首先硬件检测:

SecurAble(检测你的CPU是否支持硬件级虚拟模式)

下载地址:http://www.grc.com/securable.htm


   二、装VMware

1)安装Vmware,建议安装C盘(方便后续汉化和打补丁)

VMware-workstation-full-8.0.2-591240.exe

2)给VmwareMAC补丁

3)如果想汉化,可以拷入汉化补丁

《VMware-workstation-full-8.0.2-591240_汉化文件夹下面的文件拷入到安装路径。注意版本选择

4)补充提示,有的时候,第(2)步中提到的补丁可能打不上,原因未知,可以下载另一个网上的补丁资源

VMware_WorkstationMac补丁”

三、安装vm以及装mac 10.6

目前最好的、我装过最成功的是http://bbs.weiphone.com/read-htm-tid-1554826.html;

按照上面的步骤,肯定能成功,不行,你来找我!!!


有点要特别注意:最好不要按照上面的软件更新的方法来更新,否则,结局肯定failed,用一下方法软件更新

四、软件更新:

          若要使用Xcode 4.2,据说至少得10.6.7,当然要升肯定直接升10.6.8了。

  1、在10.6上先安装legacy_kernel-10.6.8.pkg(否则升级后无法启动Mac,弹出“虚拟CPU无效”或者“CPU被禁用”之类的提示框,升级后安装也不行,这货相当于破解吧);

  2、安装Mac OS XUpdCombo 10.6.8.dmg,安装完毕后提示重启,先淡定着不要点;

  3、安装IOUSBFamily-378.pkg,然后重启(不安装将导致鼠标键盘无效,网上那些直接粘贴覆盖的.kext文件没用,系统不会识别的);

  4、此时虚拟机再用darwin_snow_legacy.iso引导启动就无法成功了,换成RebelEFI.iso引导成功。原因不详@ @a

下载地址可参照:http://blog.csdn.net/cutesource/article/details/7715593   但是安装步骤安以上四点,需加IOUSBFamily-378.pkg

、成功安装后,进入之后没过多久出现乱码,像panic occured.We apologize for inconvenience。接着就是一大堆的乱码,这个问题曾让本来更新成功的我绝望了,难道AMD真的这么悲剧吗?后来找了一些资料发现,这个还是很好解决的,方案如下

在虚拟机硬件配置上不要太好了ˉ3ˉ主要是处理器与内存。比如你是双核处理器,配个单核就行了;你2G内存,配个1G就差不多了。【否则很容易玩着玩着就出现黑屏,显示“system configuration and what you were doing at the time that thekernel panic occured.We apologize for inconvenience.(后接一大版CPUDebug信息)”,尤其是在安装Xcode时基本上不可能完成安装。原因我揣摩着大概是虚拟机硬件配置若与真是硬件一样,可能出现抢占宿主机系统内核进程地址或者长期占用CPU,宿主机内核进程的优先级明显最高,肯定必须强制睡眠虚拟机进程。而虚拟机里的客户机实际上也有一个系统内核进程,这一睡眠哪怕100ms也完蛋了吧- -

六、安装Xcode

万里长征都是为了这货啊T T过程就不用说了,

  注意:先把系统时间(不是文件创建时间,我开始看见网上只说句“修改时间”就去改这厮了0 o)更改为201211日。(否则点击安装后会立刻提示安装失败“发生未知的安装错误,安装器遇到一个错误,导致安装失败”,原因是其证书是3月到期的);

完成了,去享受自己安装的mac 10.6.8 尽情的开发吧~~~~~~


   

阅读更多

没有更多推荐了,返回首页