poj 1386 Play on Words 【图论-欧拉路】

                                    Play on Words
                    Time Limit: 1000MS      Memory Limit: 10000K

Description
Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us.

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word “acm” can be followed by the word “motorola”. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door.

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters ‘a’ through ‘z’ will appear in the word. The same word may appear several times in the list.

Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times.
If there exists such an ordering of plates, your program should print the sentence “Ordering is possible.”. Otherwise, output the sentence “The door cannot be opened.”.

Sample Input
3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok

Sample Output
The door cannot be opened.
Ordering is possible.
The door cannot be opened.

题目大意:输入n个单词,判断是否能够连成前一个单词的尾字母与后一个单词的首字母相同的一条龙。(即:判断是否存在欧拉路通路)

AC代码:

# include <cstring>
# include <cstdio>

# define MAXN 105
# define MAXM 100005

int graph[MAXN][MAXN];
int in[MAXN];
int out[MAXN];
int vis[MAXN];

int abs(int a)
{
    if (a < 0)
    {
        return -a;
    }
    else
    {
        return a;
    }
}

void Init()
{
    memset(graph, 0, sizeof(graph));
    memset(in, 0, sizeof(in));
    memset(out, 0, sizeof(out));
    memset(vis, 0, sizeof(vis));
}

void Dfs(int u)
{
    for (int v = 1; v <= 26; v++)
    {
        if (graph[u][v] && !vis[v])
        {
            vis[v] = 1;
            Dfs(v);
        }
    }
}

bool IsCon() //判断图是否连通
{
    int con = 0;
    for (int u = 1; u <= 26; u++)
    {
        if (in[u] || out[u]) //这点有出边或入边
        {
            if (!vis[u])
            {
                vis[u] = 1;
                con++;
                Dfs(u);
            }
        }
    }

    if (con > 1)
    {
        return false;
    }
    else
    {
        return true;
    }
}

int Euler()
{
    int i;
    int inbig = 0, outbig = 0;
    for (i = 1; i <= 26; i++)
    {
        if (1 == (out[i] - in[i])) //出边大于入边 即起点
        {
            outbig++;
            if (outbig > 1)
            {
                break;
            }
        }
        else if (1 == (in[i] - out[i])) //入边大于出边 即终点
        {
            inbig++;
            if (inbig > 1)
            {
                break;
            }
        }
        else if (abs(in[i] - out[i]) > 1)
        {
            break;
        }
    }
    if (i <= 26)
    {
        return 0;
    }
    else
    {
        return 1;
    }
}

int main(void)
{
    int T;
    scanf("%d", &T);
    while (T--)
    {
        Init();
        int i, n;
        char s[1005];
        scanf("%d", &n);
        for (i = 1; i <= n; i++)
        {
            scanf("%s", s);
            int len = strlen(s);
            int u = s[0] - 'a' + 1;
            int v = s[len - 1] - 'a' + 1;
            out[u] ++;
            in[v] ++;
            graph[u][v] = graph[v][u] = 1;
        }
        if (!IsCon())
        {
            printf("The door cannot be opened.\n");
        }
        else
        {
            if (Euler())
            {
                printf("Ordering is possible.\n");
            }
            else
            {
                printf("The door cannot be opened.\n");
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值