Keywords Search
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 24734 Accepted Submission(s): 8133
Problem Description
In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.
Input
First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.
Output
Print how many keywords are contained in the description.
Sample Input
1 5 she he say shr her yasherhs
Sample Output
3
Author
Wiskey
Recommend
lcy
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
#define N 1000010
#define M 26
#define nil NULL
#define root T
struct node{
int cnt;
node *nt[M],*fail;
void init(){
memset(nt,nil,sizeof(nt));
cnt=0;fail=nil;
}
}T[N];
int cnt,ans;
void insert(char *s){//插入字典树
int k,i;
node* p=root;
for(i=0;s[i];i++){
k=s[i]-'a';
if(p->nt[k]==nil){
T[cnt].init();
p->nt[k]=&T[cnt++];
}
p=p->nt[k];
}
p->cnt++;//这里为一个单词
}
void buildFail(){
node* r= root;
queue<node*> q;
q.push( root );
while( !q.empty() ){
node* father= q.front(); q.pop();
for( int i= 0; i< 26; ++i )
if( father->nt[i] ){
node* tmp= father->fail;
while( tmp && !tmp->nt[i] ) tmp= tmp->fail;
if( !tmp ) father->nt[i]->fail= root;
else father->nt[i]->fail= tmp->nt[i];
q.push( father->nt[i] );
}
}
}
int query(char* s){//查询匹配
node* p= root;
int ans= 0;
while( *s ){
int t= *s- 'a';
while( !p->nt[t] && p!= root ) p= p->fail;
p= p->nt[t];
if( !p ) p= root;
node* tp= p;
while( tp!= root && tp->cnt!= -1 ){
ans+= tp->cnt;
tp->cnt= -1;
tp= tp->fail;}
s++;
}
return ans;
}
int main(){
int t,n;
char s[N];
scanf("%d",&t);
while(t--){
cnt=1;
T[0].init();
scanf("%d",&n);
while(n--){
scanf("%s",s);
insert(s);
}
buildFail();
scanf("%s",s);
printf("%d\n",query(s));
}
return 0;
}