hdu3091之状态压缩dp

Necklace

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 327680/327680 K (Java/Others)
Total Submission(s): 542    Accepted Submission(s): 173


Problem Description
One day , Partychen gets several beads , he wants to make these beads a necklace . But not every beads can link to each other, every bead should link to some particular bead(s). Now , Partychen wants to know how many kinds of necklace he can make.
 

Input
It consists of multi-case . 
Every case start with two integers N,M ( 1<=N<=18,M<=N*N )
The followed M lines contains two integers a,b ( 1<=a,b<=N ) which means the ath bead and the bth bead are able to be linked.
 

Output
An integer , which means the number of kinds that the necklace could be.
 

Sample Input
  
  
3 3 1 2 1 3 2 3
 

Sample Output
  
  
2
 

本题和TSP旅行商差不多,只不过本题求构成项链个数(环)则只需要从某一点出发即可,还有就是1-2-3-1和1-3-2-1是两种

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <queue>
#include <algorithm>
#include <map>
#include <cmath>
#include <iomanip>
#define INF 99999999
typedef __int64 LL;
using namespace std;

const int MAX=(1<<18)+10;
int n,m;
LL dp[MAX][20];
bool edge[20][20];

void DP(){
	int bit=1<<n;
	memset(dp,0,sizeof dp); 
	dp[1][0]=1;
	for(int i=1;i<bit;++i){
		for(int j=0;j<n;++j){
			if(dp[i][j] == 0)continue;
			for(int k=1;k<n;++k){
				if(i&(1<<k))continue;
				if(!edge[j][k])continue;
				dp[i|(1<<k)][k]+=dp[i][j];
			}
		}
	}
	LL sum=0;
	for(int i=0;i<n;++i)if(edge[0][i])sum+=dp[bit-1][i];
	printf("%I64d\n",sum);
}

int main(){
	int u,v;
	while(~scanf("%d%d",&n,&m)){
		memset(edge,false,sizeof edge);
		for(int i=0;i<m;++i){
			scanf("%d%d",&u,&v);
			--u,--v;
			edge[u][v]=edge[v][u]=true;
		}
		DP();
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值