hdu1964之插头DP求最优值

Pipes

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 477    Accepted Submission(s): 238


Problem Description
The construction of office buildings has become a very standardized task. Pre-fabricated modules are combined according to the customer’s needs, shipped from a faraway factory, and assembled on the construction site. However, there are still some tasks that require careful planning, one example being the routing of pipes for the heating system. 

Amodern office building ismade up of squaremodules, one on each floor being a service module from which (among other things) hot water is pumped out to the other modules through the heating pipes. Each module (including the service module) will have heating pipes connecting it to exactly two of its two to four neighboring modules. Thus, the pipes have to run in a circuit, from the service module, visiting each module exactly once, before finally returning to the service module. Due to different properties of the modules, having pipes connecting a pair of adjacent modules comes at different costs. For example, some modules are separated by thick walls, increasing the cost of laying pipes. Your task is to, given a description of a floor of an office building, decide the cheapest way to route the heating pipes.
 

Input
The first line of input contains a single integer, stating the number of floors to handle. Then follow n floor descriptions, each beginning on a new line with two integers, 2 <= r <= 10 and 2 <= c <= 10, defining the size of the floor – r-by-c modules. Beginning on the next line follows a floor description in ASCII format, in total 2r + 1 rows, each with 2c + 2 characters, including the final newline. All floors are perfectly rectangular, and will always have an even number of modules. All interior walls are represented by numeric characters, ’0’ to ’9’, indicating the cost of routing pipes through the wall (see sample input).
 

Output
For each test case, output a single line with the cost of the cheapest route.
 

Sample Input
  
  
3 4 3 ####### # 2 3 # #1#9#1# # 2 3 # #1#7#1# # 5 3 # #1#9#1# # 2 3 # ####### 4 4 ######### # 2 3 3 # #1#9#1#4# # 2 3 6 # #1#7#1#5# # 5 3 1 # #1#9#1#7# # 2 3 0 # ######### 2 2 ##### # 1 # #2#3# # 4 # #####
 

Sample Output
  
  
28 45 10
 

题意有点难理解,直接看输入好了,空格表示可通过的点,数字表示相邻点之间通过所需要的花费

问通过所有点并回到原点所需要的最少花费

插头DP模板题,只需要将到达某个状态的数量改成最少花费即可

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <queue>
#include <algorithm>
#include <map>
#include <cmath>
#include <iomanip>
#define INF 99999999
typedef long long LL;
using namespace std;

const int MAX=100000+10;
const int N=10+10;
int n,m,size,index;
int mp[N][N],w[N][N][N][N],total[2],bit[N];//w[i][j][k][t]表示i,j->k,t的花费 
int head[MAX],next[MAX],Hash[MAX];
LL dp[2][MAX],state[2][MAX],sum;//dp记录到达相应状态的最少花费 

void Init(){
	memset(mp,0,sizeof mp);
	for(int i=1;i<=n;++i)for(int j=1;j<=m;++j)mp[i][j]=1;
	index=0;
	sum=INF;
	total[index]=1;
	dp[index][1]=0;
	state[index][1]=0;
}

void HashCalState(LL s,LL v){
	int pos=s%MAX;
	for(int i=head[pos];i != -1;i=next[i]){
		if(state[index][Hash[i]] == s){
			dp[index][Hash[i]]=min(dp[index][Hash[i]],v);
			return;
		}
	}
	++total[index];
	state[index][total[index]]=s;
	dp[index][total[index]]=v;
	//头插法
	Hash[size]=total[index];
	next[size]=head[pos];
	head[pos]=size++; 
}

void DP(){//采用4进制括号表示法 
	for(int i=1;i<=n;++i){
		for(int k=1;k<=total[index];++k)state[index][k]<<=2;//由上一行到本行最后一个插头(0)去掉,在头增加一个插头(0) 
		for(int j=1;j<=m;++j){//决策i,j格 
			memset(head,-1,sizeof head);
			size=0;
			index=index^1;
			total[index]=0;
			for(int k=1;k<=total[index^1];++k){//上一格的有效状态数 
				LL s=state[index^1][k];
				LL v=dp[index^1][k];
				int p=(s>>bit[j-1])%4;
				int q=(s>>bit[j])%4;
				//这里就不用判断mp[i][j]是否可以通过,因为这里一定能通过 
				if(!p && !q){//创建新连通块
					if(!mp[i][j+1] || !mp[i+1][j])continue;
					s=s+(1<<bit[j-1])+2*(1<<bit[j]);
					v=v+w[i][j][i][j+1]+w[i][j][i+1][j];
					HashCalState(s,v);
				}else if(!p && q){
					if(mp[i][j+1])HashCalState(s,v+w[i][j][i][j+1]);
					if(mp[i+1][j]){
						s=s+q*(1<<bit[j-1])-q*(1<<bit[j]);
						v=v+w[i][j][i+1][j];
						HashCalState(s,v);
					}
				}else if(p && !q){
					if(mp[i+1][j])HashCalState(s,v+w[i][j][i+1][j]);
					if(mp[i][j+1]){
						s=s-p*(1<<bit[j-1])+p*(1<<bit[j]);
						v=v+w[i][j][i][j+1];
						HashCalState(s,v);
					}
				}else if(p == 1 && q == 1){
					int b=1;
					for(int t=j+1;t<=m;++t){
						int a=(s>>bit[t])%4;
						if(a == 1)++b;
						if(a == 2)--b;
						if(!b){
							s=s+(1<<bit[t])-2*(1<<bit[t]);
							break;
						}
					}
					s=s-(1<<bit[j-1])-(1<<bit[j]);
					HashCalState(s,v);
				}else if(p == 2 && q == 2){
					int b=1;
					for(int t=j-2;t>=0;--t){
						int a=(s>>bit[t])%4;
						if(a == 2)++b;
						if(a == 1)--b;
						if(!b){
							s=s-(1<<bit[t])+2*(1<<bit[t]);
							break;
						}						
					}
					s=s-2*(1<<bit[j-1])-2*(1<<bit[j]);
					HashCalState(s,v);
				}else if(p == 1 && q == 2){
					if(i == n && j == m)sum=min(sum,v);
				}else if(p == 2 && q == 1){
					s=s-2*(1<<bit[j-1])-(1<<bit[j]);
					HashCalState(s,v);
				}
			}
		}
	}
}

int main(){
	for(int i=0;i<N;++i)bit[i]=i<<1;
	int t;
	char s[N+N];
	scanf("%d",&t);
	while(t--){
		scanf("%d%d%*c",&n,&m);
		Init();
		gets(s);
		for(int i=1;i<=n;++i){
			gets(s);
			for(int j=2;j<2*m+1;j+=2){
				w[i][j/2][i][j/2+1]=s[j]-'0';
			}
			gets(s);
			for(int j=1;j<2*m+1;j+=2){
				w[i][j/2+1][i+1][j/2+1]=s[j]-'0';
			}
		}
		DP();
		printf("%lld\n",sum);
	}
	return 0;
} 


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值