hdu4288之线段树单点更新

Problem Description
  In mathematics and computer science, an algorithm describes a set of procedures or instructions that define a procedure. The term has become increasing popular since the advent of cheap and reliable computers. Many companies now employ a single coder to write an algorithm that will replace many other employees. An added benefit to the employer is that the coder will also become redundant once their work is done.  1
  You are now the signle coder, and have been assigned a new task writing code, since your boss would like to replace many other employees (and you when you become redundant once your task is complete).
Your code should be able to complete a task to replace these employees who do nothing all day but eating: make the digest sum.
  By saying “digest sum” we study some properties of data. For the sake of simplicity, our data is a set of integers. Your code should give response to following operations:
  1. add x – add the element x to the set;
  2. del x – remove the element x from the set;
  3. sum – find the digest sum of the set. The digest sum should be understood by

  where the set S is written as {a 1, a 2, ... , a k} satisfying a 1 < a 2 < a 3 < ... < a k 
  Can you complete this task (and be then fired)?
------------------------------------------------------------------------------
1 See http://uncyclopedia.wikia.com/wiki/Algorithm
 

Input
  There’re several test cases.
  In each test case, the first line contains one integer N ( 1 <= N <= 10 5 ), the number of operations to process.
  Then following is n lines, each one containing one of three operations: “add x” or “del x” or “sum”.
  You may assume that 1 <= x <= 10 9.
  Please see the sample for detailed format.
  For any “add x” it is guaranteed that x is not currently in the set just before this operation.
  For any “del x” it is guaranteed that x must currently be in the set just before this operation.
  Please process until EOF (End Of File).
 

Output
  For each operation “sum” please print one line containing exactly one integer denoting the digest sum of the current set. Print 0 if the set is empty.
 

Sample Input
  
  
9 add 1 add 2 add 3 add 4 add 5 sum add 6 del 3 sum 6 add 1 add 3 add 5 add 7 add 9 sum
 

Sample Output
  
  
3 4 5

有三种类型的操作,(1)."add x",表示往集合里添加数x。(2).“del x”表示将集合中数x删除。(3).“sum”求出从小到大排列的集合中下标模5为3的数的和。集合中的数都是唯一的。


#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<iomanip>
#define INF 99999999
using namespace std;

const int MAX=100000+10;
const int mod=5;
int sum[MAX<<2];//表示区间内数的个数 
__int64 num[MAX<<2][mod];//表示区间内所有%mod=[0~4]的和
int s[MAX],x[MAX];
char oper[MAX][4];

void BuildTree(int n,int left,int right){
	sum[n]=0;
	for(int i=0;i<mod;++i)num[n][i]=0;
	if(left == right)return;
	int mid=left+right>>1;
	BuildTree(n<<1,left,mid);
	BuildTree(n<<1|1,mid+1,right);
}

void Upfather(int n){
	for(int i=0;i<mod;++i){
		num[n][i]=num[n<<1][i]+num[n<<1|1][(i+mod-sum[n<<1]%mod)%mod];//sum[n<<1]%mod+x=i+mod*n(n=0,1,2,...),x=i+mod-...
	} 
}

void Update(int pos,int date,bool flag,int n,int left,int right){
	if(flag)++sum[n];
	else --sum[n];
	if(left == right){num[n][1]=(flag?date:0);return;}
	int mid=left+right>>1;
	if(pos<=mid)Update(pos,date,flag,n<<1,left,mid);
	else Update(pos,date,flag,n<<1|1,mid+1,right);
	Upfather(n);
}

int search(int key,int hash[],int n){//lower_bound
	int left=0,right=n-1;
	while(left<right){
		int mid=left+right>>1;
		if(hash[mid]<key)left=mid+1;
		else right=mid;
	}
	return left;
}

int main(){
	int n;
	while(cin>>n){
		int k=0;
		for(int i=0;i<n;++i){
			scanf("%s",oper[i]);
			if(oper[i][0] != 's'){
				scanf("%I64d",&x[i]);
				s[k++]=x[i];//相当于x[i]大区间hash到k这个小区间 
			}
		}
		sort(s,s+k);//s是确定每个数的位置
		BuildTree(1,1,k);//memset(sum,0,sizeof sum),memset(num,0,sizeof num);
		for(int i=0;i<n;++i){
			if(oper[i][0] == 's')printf("%I64d\n",num[1][3]);
			else{
				int pos=search(x[i],s,k);//查询第一个小于等于x[i]的数的位置 
				Update(pos,x[i],oper[i][0] == 'a',1,1,k);
			}
		} 
	}
	return 0;
} 

简洁版

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<iomanip>
#define INF 99999999
using namespace std;

/*
思路:由于要计算排序后位置mod%5为3的所有数的和,
所以先对所有的数排序后再插入就行了,同时由于插入/删除数,
所以插入/删除的位置的右边的mod%5=[0~4]的值需要变,可以通过左孩子数的个数来维护 
*/ 
const int MAX=100000+10;
int sum[MAX<<2];//表示含有数的个数
__int64 num[MAX<<2][5];//表示mod%5=[0~4]的位置数总和
char op[MAX][4];
int s[MAX],hash[MAX];

void Update(int pos,int date,bool flag,int n,int left,int right){
	if(flag)++sum[n];
	else --sum[n];
	if(left == right){num[n][1]=(flag?date:0);return;}
	int mid=left+right>>1;
	if(pos<=mid)Update(pos,date,flag,n<<1,left,mid);
	else Update(pos,date,flag,n<<1|1,mid+1,right);
	for(int i=0;i<5;++i){
		num[n][i]=num[n<<1][i]+num[n<<1|1][(i+5-sum[n<<1]%5)%5];//sum[n<<1]%5+x=i+5=>x=i+5-....
	}
}

int search(int key,int x[],int n){
	int left=1,right=n-1;
	while(left<right){
		int mid=left+right>>1;
		if(x[mid]<key)left=mid+1;
		else right=mid;
	}
	return left;
}

int main(){
	int n;
	while(cin>>n){
		int k=0;
		for(int i=0;i<n;++i){
			scanf("%s",op[i]);
			if(op[i][0] != 's'){
				scanf("%d",&s[i]);
				hash[k++]=s[i];
			}
		}
		int m=1;
		sort(hash,hash+k);
		for(int i=1;i<k;++i)if(hash[i] != hash[i-1])hash[m++]=hash[i];
		memset(sum,0,sizeof sum);
		memset(num,0,sizeof num);
		for(int i=0;i<n;++i){
			if(op[i][0] == 's')printf("%I64d\n",num[1][3]);
			else{
				int pos=search(s[i],hash,m);
				Update(pos,s[i],op[i][0] == 'a',1,1,m);
			}
		}
	}
	return 0;
} 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值