Language:
Period
Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A
K ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input
The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the
number zero on it. Output
For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input 3 aaa 12 aabaabaabaab 0 Sample Output Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4 |
题目意思是给定一个长为n的字符串求字符串的前几位是循环字串并且求出循环次数
思路:对于一个长度为len的字符串,其可能周期=len-(len-next[len]),这个周期其实是多次循环后包含原串,并不是等于原串,所以要len%(len-next[len]) == 0来判断是否等于原串
这个所谓的周期是多次循环后包含原串,例如aaaabbaa=>求得周期是aaaabb
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<iomanip>
#define INF 99999999
using namespace std;
const int MAX=1000000+10;
char s[MAX];
int next[MAX];
void get_next(char *a){
int i=-1,j=0,len=strlen(a);
next[0]=-1;
while(j<len){
if(i == -1 || a[i] == a[j])next[++j]=++i;
else i=next[i];
}
for(int i=2;i<=len;++i){//前i个字符,i-next[i]是前i个字符的周期
if(i%(i-next[i]) == 0 && i/(i-next[i])>1)cout<<i<<' '<<i/(i-next[i])<<endl;
}
return;
}
int main(){
int n,num=0;
while(cin>>n,n){
cin>>s;
cout<<"Test case #"<<++num<<endl;
get_next(s);
cout<<endl;
}
return 0;
}