hdu1547之BFS

Bubble Shooter

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 596    Accepted Submission(s): 239


Problem Description
Bubble shooter is a popular game. You can find a lot of versions from the Internet.



The goal of this game is to clean the bubbles off the field. Every time you just point the cannon to where you want the next bubble to go, and if three or more of bubbles with the same color came together (including the newly shot bubble), they will detonate. After the first explode, if some bubbles are disconnected from the bubble(s) in the topmost row, they will explode too.

In this problem, you will be given an arranged situation of bubbles in the field and the newly shot bubble. Your program should output the total number of bubbles that will explode.
 

Input
There are multiple test cases. Each test case begins with four integers H (the height of the field, 2 <= H <= 100), W (the width of the field, 2 <= W <= 100, in the picture above, W is 10), h (the vertical position of the newly shot bubble, count from top to bottom, and the topmost is counted as 1) and w (the horizontal position of the newly shot bubble, count from left to right, and the leftmost is counted as 1). 
Then H lines follow, the odd lines will contain W characters while the even lines will contain W-1 characters (refer to the picture above). Each character will be either a lowercase from 'a' to 'z' indicating the color of the bubble in that position, or a capital letter 'E' indicating an empty position. You may assure the arranged situation is always valid (all the bubbles are directly or indirectly connected with at least one bubble in the topmost row, and the position of newly shot bubble is never empty).
 

Output
For each test case, output an integer indicating how many bubbles will explode.
 

Sample Input
  
  
2 2 2 1 aa a 3 3 3 3 aaa ba bba 3 3 3 1 aaa ba bba 3 3 3 3 aaa Ea aab
 

Sample Output
  
  
3 8 3 0
 
题意:输入n行m列,和发出小球的到达的位置h,w,用a~z表示不同颜色的小球,E表示该位置为空,另外奇数行有m个小球位置,偶数行有m-1个小球位置

求发射出该小球后掉落的小球数量有多少,已知相同颜色的小球连通数量>=3就会掉落和悬空的小球也会掉落(即周围没有小球与它相连)


分析:先从发射出的小球那开始广搜,判断相同颜色连通的数量是否>=3,是则将这些位置标记为空

然后对第一行小球位置开始搜索,所有搜索到的小球都不是悬空的,即不会掉落,没搜索到的会掉落

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<iomanip>
#define INF 99999999
using namespace std;

const int MAX=100+10;
char Map[MAX][MAX];
int n,m,sx,sy,s[MAX*MAX];
int dir0[6][2]={0,1,0,-1,1,0,-1,0,-1,-1,1,-1};//偶数行能走得方向(行下标从0开始)
int dir1[6][2]={0,1,0,-1,1,0,-1,0,-1,1,1,1};//奇数行能走得方向 

int BFS(bool flag,int sx,int sy){
	char ch=Map[sx][sy];
	Map[sx][sy]='E';
	int sum=0;
	queue<int>q;
	int oq,a,b;
	q.push(sx*m+sy);//将第x*n+y个点入队
	while(!q.empty()){
		oq=q.front();
		q.pop();
		if(flag)s[sum]=oq;//先记录点,如果sum<3则需要还原点 
		++sum;
		int x=oq/m,y=oq%m;
		for(int i=0;i<6;++i){
			if(x%2)a=x+dir1[i][0],b=y+dir1[i][1];
			else a=x+dir0[i][0],b=y+dir0[i][1];
			if(a<0 || b<0 || a>=n || (a%2 && b>=m-1) || b>=m)continue;
			if(Map[a][b] == 'E')continue;//表示该点为空
			if(flag && Map[a][b] != ch)continue;//查找周围连通且相同颜色的球 
			Map[a][b]='E';
			q.push(a*m+b);
		}
	}
	if(flag && sum<3){
		for(int i=0;i<sum;++i)Map[s[i]/m][s[i]%m]=ch;
	}
	return sum;
}

int main(){
	while(cin>>n>>m>>sx>>sy){
		--sx,--sy;
		for(int i=0;i<n;++i)cin>>Map[i];
		int ans=0,sum=0;//sum表示总的球数
		for(int i=0;i<n;++i){
			for(int j=0;j<m;++j){
				if(Map[i][j]>='a' && Map[i][j]<='z')++sum;
			}
		}
		BFS(true,sx,sy);
		for(int i=0;i<m;++i){
			if(Map[0][i] != 'E')ans+=BFS(false,0,i);//查询与顶上连通的球 
		}
		cout<<sum-ans<<endl;
	}
	return 0;
}


“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值