POJ Mayor's posters (线段树成段更新 离散化666)

Mayor's posters

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 1   Accepted Submission(s) : 1
Problem Description
The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 
  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
  • The wall is divided into segments and the width of each segment is one byte. 
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall. 
 

Input
The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l<sub>i</sub> and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l<sub>i</sub> <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l<sub>i</sub>, l<sub>i</sub>+1 ,... , ri.
 

Output
For each input data set print the number of visible posters after all the posters are placed. <br> <br>The picture below illustrates the case of the sample input. <br><img src=images/2528_1.jpg>
 

Sample Input
  
  
1 5 1 4 2 6 8 10 3 4 7 10
 

Sample Output
  
  
4
 

Source
PKU
 

题意:每一行给出一个范围,最后判断出能看到几张海报

思路:能想到是线段树的成段更新,关键是如何统计出有几张能看到的呢,这一题就用到了类似于延迟标记的push_down来得到的,即把每张海报都进行标号,最后有几个标号,就有几张可以看到,难点在于想到数据的离散化,因为数据很大,所以可以把数字往小范围的一对一的对应,就是对数据进行排序,然后去重复的数字,最后再对应数字,
不过问题又来了,对于
1 10
1 4
5 10
1 10
1 4
6 10
这两组数据时行不通的,所以这个时候看到大神的代码需要在前后两个数之间大于1的之间在加一个数,来解决这个问题。。。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#define Max 13010
#define ls l,m,rt<<1
#define rs m+1,r,rt<<1|1
using namespace std;

int cnt[Max<<4];
int hash[Max<<1];
int X[Max<<2];
int num;

void push_down(int rt)
{
	if(cnt[rt] != -1)
	{
		cnt[rt<<1] = cnt[rt<<1|1] = cnt[rt];
		cnt[rt] = -1;
	}
}

void update(int L,int R,int add,int l,int r,int rt)
{
	if(L<=l && R>=r)
	{
		cnt[rt] = add;
		return ;
	}
	  
	int m = (l+r)>>1;
	push_down(rt);
	
	if(L <= m)
		update(L,R,add,ls);
	if(R > m)
		update(L,R,add,rs);
}

void query(int l,int r,int rt)
{
	if(cnt[rt] != -1)
	{
		if(!hash[cnt[rt]])
			num++;
		hash[cnt[rt]] = 1;
		return ;
	}

	if(l == r)
		return ;

	int m = (l+r)>>1;
	query(ls);
	query(rs);
}

int lisan(int x,int tt)
{
	int l = 1,r = tt-1;
	int i,m;

	while(l <= r)
	{
		m = (l+r)>>1;
		if(X[m] == x)
			return m;

		if(X[m] < x)
			l = m + 1;
		else
			r = m - 1;

	}

	return 0;
}

int main()
{
    int n,m,t,nnn,tt,l,r;
	int i,j,k;
	int x[Max],y[Max];

	scanf("%d",&nnn);

	while(nnn--)
	{
		scanf("%d",&n);
		memset(cnt,-1,sizeof(cnt));
		memset(X,0,sizeof(X));

		num = 0 ;

		for(i=1,k=1;i<=n;i++)
		{
			scanf("%d%d",&x[i],&y[i]);
			X[k++] = x[i];
			X[k++] = y[i];
		}

		sort(X+1,X+k);

		tt=1;
		for(i=1;i<k;i++)//去重复
		{
			if(X[i] != X[i-1])
				X[tt++] = X[i];
		}

		for(i=tt-1;i>=1;i--)
		{
			if(X[i] != X[i-1] + 1)
				X[tt++] = X[i-1] + 1;
		}

		sort(X+1,X+tt);

		for(i=1;i<=n;i++)
		{
			l = lisan(x[i],tt);
			r = lisan(y[i],tt);
			//cout<<l<<" "<<r<<endl;
			update(l,r,i,1,tt-1,1);
		}

		memset(hash,0,sizeof(hash));

		query(1,tt-1,1);

		cout<<num<<endl;
	}

    return 0; 
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园的建设目标是通过数据整合、全面共享,实现校园内教学、科研、管理、服务流程的数字化、信息化、智能化和多媒体化,以提高资源利用率和管理效率,确保校园安全。 智慧校园的建设思路包括构建统一支撑平台、建立完善管理体系、大数据辅助决策和建设校园智慧环境。通过云架构的数据中心与智慧的学习、办公环境,实现日常教学活动、资源建设情况、学业水平情况的全面统计和分析,为决策提供辅助。此外,智慧校园还涵盖了多媒体教学、智慧录播、电子图书馆、VR教室等多种教学模式,以及校园网络、智慧班牌、校园广播等教务管理功能,旨在提升教学品质和管理水平。 智慧校园的详细方案设计进一步细化了教学、教务、安防和运维等多个方面的应用。例如,在智慧教学领域,通过多媒体教学、智慧录播、电子图书馆等技术,实现教学资源的共享和教学模式的创新。在智慧教务方面,校园网络、考场监控、智慧班牌等系统为校园管理提供了便捷和高效。智慧安防系统包括视频监控、一键报警、阳光厨房等,确保校园安全。智慧运维则通过综合管理平台、设备管理、能效管理和资产管理,实现校园设施的智能化管理。 智慧校园的优势和价值体现在个性化互动的智慧教学、协同高效的校园管理、无处不在的校园学习、全面感知的校园环境和轻松便捷的校园生活等方面。通过智慧校园的建设,可以促进教育资源的均衡化,提高教育质量和管理效率,同时保障校园安全和提升师生的学习体验。 总之,智慧校园解决方案通过整合现代信息技术,如云计算、大数据、物联网和人工智能,为教育行业带来了革命性的变革。它不仅提高了教育的质量和效率,还为师生创造了一个更加安全、便捷和富有智慧的学习与生活环境。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值