POJ+2528+Mayor's posters(线段树,离散化)

Mayor's posters


Problem Description
The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 
  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
  • The wall is divided into segments and the width of each segment is one byte. 
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall. 
 

Input
The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l<sub>i</sub> and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l<sub>i</sub> <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l<sub>i</sub>, l<sub>i</sub>+1 ,... , ri.
 

Output
For each input data set print the number of visible posters after all the posters are placed. <br> <br>The picture below illustrates the case of the sample input. <br><img src=images/2528_1.jpg>
 

Sample Input
  
  
1 5 1 4 2 6 8 10 3 4 7 10
 

Sample Output
  
  
4

这里的离散化方法是,如果相邻数字间距大于1的话,在其中加上任意一个数字,主要就是让本来不相邻的数继续保持不相邻即可.

代码:

//先贴的是父节点
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
#define M 11111
bool vis[M];  //记录看到的海报
int cnt,m;
int tree[M<<4];
int l[M],r[M],x[M*4]; //x存放每一个坐标,用于在bin函数中返回坐标对应的下标
void pushdown(int rt)
{
    if(tree[rt]!=-1)
    {
        tree[rt<<1]=tree[rt<<1|1]=tree[rt];
        tree[rt]=-1;
    }
}
void update(int ql,int qr,int c,int l,int r,int rt)
{
    if(ql<=l&&qr>=r)
    {
        tree[rt]=c;
        return ;
    }
    pushdown(rt);
    int mid=(l+r)>>1;
    if(ql<=mid) update(ql,qr,c,lson);
    if(qr>mid) update(ql,qr,c,rson);
}
void query(int l,int r,int rt)
{
    if(tree[rt]!=-1)
    {
        if(vis[tree[rt]]==false)
        {
            cnt++;
        }
        vis[tree[rt]]=true;
        return;
    }
    if(l==r) return;
    int mid=(l+r)>>1;
    query(lson);
    query(rson);
}
int bin(int key)
{
    int l=0,r=m-1,mid;
    while(l<=r)
    {
        mid=(l+r)>>1;
        if(x[mid]==key) return mid;
        if(x[mid]>key) r=mid-1;
        else l=mid+1;
    }
    return -1;
}
int main()
{
    int T,n,i,num;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        num=0;
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&l[i],&r[i]);
            x[num++]=l[i];
            x[num++]=r[i];
        }
        sort(x,x+num);
        m=1;
        for(i=1;i<num;i++) //去掉重复
        {
            if(x[i]!=x[i-1]) x[m++]=x[i];
        }
        for(i=m-1;i>0;i--) //如果相邻数字间距大于1的话,在其中间加上一个数字
        {
            if(x[i]!=x[i-1]+1) x[m++]=x[i-1]+1;
        }
        sort(x,x+m); //m是海报个数,也是区间长度
        memset(tree,-1,sizeof(tree));
        for(i=0;i<n;i++)
        {
            int left=bin(l[i]); 
            int right=bin(r[i]);
            update(left,right,i,0,m-1,1);
        }
        cnt=0;
        memset(vis,false,sizeof(vis));
        query(0,m-1,1);
        printf("%d\n",cnt);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值