CSU-ACM2017暑期训练1-Debug与STL A - Surprising Strings

A - Surprising Strings

The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible distance D.

Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)

Acknowledgement: This problem is inspired by the "Puzzling Adventures" column in the December 2003 issue of Scientific American.

Input

The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.

Output

For each string of letters, output whether or not it is surprising using the exact output format shown below.

Sample Input

ZGBG
X
EE
AAB
AABA
AABB
BCBABCC
*

Sample Output

ZGBG is surprising.
X is surprising.
EE is surprising.
AAB is surprising.
AABA is surprising.
AABB is NOT surprising.
BCBABCC is NOT surprising.

这题用pair做枚举,给定的字符串中取出的pair有多组,每组是按不同间隔(0 ~ str.length - 2)从字符串中取出的多对字符。如果从一个字符串中取出的每一组的组内的每一对字符是唯一的,就称它是Surprising String。

#include <iostream>
#include <vector>
#include <utility>
#include <string>
using namespace std;
int main(){

    pair<char, char> myPair;
    vector<pair<char,char> > myVec;
    string str;
    while(cin >> str){
        int lenOfStr = str.length();
        if(str == "*")
            break;
        myVec.clear();
        if(str.length() > 2){
            int i;
            for(i = 0; i < str.length()-2; i++){
            //按D的所有可能长度循环。

                bool isThisUnique = true;
                myVec.clear();
                for(int j = 0; j < lenOfStr - i - 1; j++){
                //在确保不越界的情况下将pair的first向右移动,找出所有pair。

                    myPair = make_pair(str[j], str[j + i + 1]);
                    int k;
                    for(k = 0; k < myVec.size(); k++){    
                    //判断是否为D-Unique

                        if(myVec[k].first == myPair.first && myVec[k].second == myPair.second){
                            isThisUnique = false;
                            break;
                        }
                    }
                    if(k == myVec.size())
                        myVec.push_back(make_pair(str[j], str[j + i + 1]));
                    else
                        break;
                }
                if(!isThisUnique)
                    break;
            }
            if(i == str.length() - 2)
                cout << str << " is surprising." << endl;
            else
                cout << str << " is NOT surprising." << endl;
        }
        else
            cout << str << " is surprising." << endl;
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值