CSU-ACM2017暑假集训2-二分搜索 C - 4 Values whose Sum is 0

C - 4 Values whose Sum is 0

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n . 

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D . 

Output

For each input file, your program has to write the number quadruplets whose sum is zero. 

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30). 

有四个vector,每个vector的元素至多4000,挨个枚举复杂度O(n^4),肯定超时。所以vcvd 相加得到 vSum2,再遍历 vavb,当总和为零的quadruplet存在时,有以下关系:

x,y[0,n),i[0,vSum2.size()),   0va[x]vb[y]=vSum2[i]

因此可以用 quantitiy=upper_bound()lower_bound() vSum2 中统计数值为 va[x]vb[y] 的元素的个数(不存在时, quantity 自然为零)。

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <vector>
#include <map>
using namespace std;
int main(){

    int n;
    while(cin >> n){
        vector<int> va, vb, vc, vd, vSum1, vSum2;
        map<int,int> myMap;
        int ta, tc, tb, td;
        for(int i = 0; i < n; i++){
            scanf("%d%d%d%d", &ta, &tb, &tc, &td);
            va.push_back(ta), vb.push_back(tb), vc.push_back(tc), vd.push_back(td);
        }
        for(int i = 0; i < n; i++){
            for(int j = 0; j < n; j++){
                vSum2.push_back(vc[j] + vd[i]);
            }
        }
        sort(vSum2.begin(), vSum2.end());
        int quantity = 0;
        for(int i = 0; i < n; i++)
            for(int j = 0; j < n; j++){
                quantity += upper_bound(vSum2.begin(), vSum2.end(), -va[i] - vb[j]) - lower_bound(vSum2.begin(), vSum2.end(), -va[i] - vb[j]);
            }
        cout << quantity << endl;
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值