CSU-ACM2017暑期训练1-Debug与STL E - Train Problem I

E - Train Problem I

 As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.

123
Input

The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.

Output

The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.

Sample Input

3 123 321
3 123 312

Sample Output

Yes.
in
in
in
out
out
out
FINISH
No.
FINISH




For the first Sample Input, we let train 1 get in, then train 2 and train 3.
So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.
In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.
Now we can let train 3 leave.
But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
So we output "No.".

按照入站顺序将列车入栈,每入一列与出站序列进行比较,若与出站序列首位对应,则将栈顶列车弹出,出站序列首位后移一位,出站计数器加一,继续比较栈顶和序列首位,直到全部列车都出站,此时出站计数器数值等于列车数,可以按记录输出结果。否则输出”No.”。

#include <iostream>
#include <stack>
#include <string>
#include <cstring>
using namespace std;
int main(){

    stack<char> trainStack;
    string trainIn, trainOut;
    int n;
    while(cin >> n){
        int actionIndex = 0;
        while(!trainStack.empty())
            trainStack.pop();
        bool action[20];                     //1表示入站,0表示出站
        memset(action, 0, sizeof(action));   //初始化为0
        cin >> trainIn >> trainOut;
        int sizeOfTrainIn = trainIn.length(), sizeCounter = 0;
        int i, j = 0;
        //j是计数器,表示能按照出站顺序行动的列车数目

        for(i = 0; i < sizeOfTrainIn; i++){
            trainStack.push(trainIn[i]);
            action[actionIndex++] = 1;       //入站一列
            while(!trainStack.empty() && trainStack.top() == trainOut[j]){
            //判断出站列表的第一位是否是刚刚进站的,若是,将它出站

                trainStack.pop();
                actionIndex++;
                //此时的action[actionIndex]已经为0,跳过它就行

                j++;
            }
        }
        if(j == sizeOfTrainIn){
            cout << "Yes." << endl;
            for(int j = 0; j < n * 2; j++){
                if(action[j])
                    cout << "in" << endl;
                else
                    cout << "out" << endl;
            }
            cout << "FINISH" << endl;
        }
        else{
            cout << "No." << endl << "FINISH" << endl;
        }
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值