CSU-ACM2017暑期训练16-树状数组 G - KiKi's K-Number HDU - 2852

G - KiKi’s K-Number

   For the k-th number, we all should be very familiar with it. Of course,to kiki it is also simple. Now Kiki meets a very similar problem, kiki wants to design a container, the container is to support the three operations.

Push: Push a given element e to container

Pop: Pop element of a given e from container

Query: Given two elements a and k, query the kth larger number which greater than a in container;

Although Kiki is very intelligent, she can not think of how to do it, can you help her to solve this problem?

Input

Input some groups of test data ,each test data the first number is an integer m (1 <= m <100000), means that the number of operation to do. The next m lines, each line will be an integer p at the beginning, p which has three values:
If p is 0, then there will be an integer e (0 <e <100000), means press element e into Container.

If p is 1, then there will be an integer e (0 <e <100000), indicated that delete the element e from the container  

If p is 2, then there will be two integers a and k (0 <a <100000, 0 <k <10000),means the inquiries, the element is greater than a, and the k-th larger number.

Output

For each deletion, if you want to delete the element which does not exist, the output "No Elment!". For each query, output the suitable answers in line .if the number does not exist, the output "Not Find!".

Sample Input

5
0 5
1 2
0 6
2 3 2
2 8 1
7
0 2
0 2
0 4
2 1 1
2 1 2
2 1 3
2 1 4

Sample Output

No Elment!
6
Not Find!
2
2
4
Not Find!

使用一个树状数组来解决这个问题:用数组元素的值表示数字 x 在容器中有几份。
这样描述问题后,只需在压入时给对应的点加一,在删除时判断待删元素的数量是否大于零,查找比 a 大的第 k <script type="math/tex" id="MathJax-Element-102">k</script> 个元素时使用二分查找,看看是否存在这样的元素即可。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <vector>
#include <cstring>
#include <queue>
using namespace std;
const int maxn = 1e5+19;

int m, e, x, y;

int c[maxn];

void add(int x, int d){
    while(x <= maxn){
        c[x] += d; x += x&-x;
    }
}

int sum(int x){
    int ret = 0;
    while(x > 0){
        ret += c[x]; x -= x&-x;
    }
    return ret;
}

int main(){
#ifdef TEST
freopen("test.txt", "r", stdin);
#endif // TEST

    while(cin >> m){
        memset(c, 0, sizeof(c));
        for(int i = 0; i < m; i++){
            scanf("%d%d", &e, &x);
            if(e == 0){
                add(x, 1);
            }
            if(e == 1){
                if(sum(x)-sum(x-1) == 0){
                    printf("No Elment!\n");
                    continue;
                }
                add(x, -1);
            }
            if(e == 2){
                scanf("%d", &y);
                int left = x+1, right = maxn, mid, ans;
                while(left <= right){
                    mid = (left + right) >> 1;
                    if(sum(mid)-sum(x) >= y){ // mid is too large or just it.
                        ans = mid;
                        right = mid - 1;
                    }
                    else                      // mid is too small.
                        left = mid + 1;
                }
                if(left >= maxn)
                    printf("Not Find!\n");
                else
                    printf("%d\n", ans);
            }
        }
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值