PTA玩转二叉树

7-26 玩转二叉树 (25 分)

给定一棵二叉树的中序遍历和前序遍历,请你先将树做个镜面反转,再输出反转后的层序遍历的序列。所谓镜面反转,是指将所有非叶结点的左右孩子对换。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其中序遍历序列。第三行给出其前序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树反转后的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
1 2 3 4 5 6 7
4 1 3 2 6 5 7

输出样例:

4 6 1 7 5 3 2
#include<bits/stdc++.h>
using namespace std;
struct Node{ int l;int r;}a[1000];
int pre[1000],mid[1000],n;
int build(int ml,int mr,int pl,int pr){
	if(ml>mr)return 0;//如果不正常返回0,也就是叶节点的下一个结点	
	int root=pre[pl],p1,num,index=ml;
	while(mid[index]!=pre[pl])index++;
	num=index-ml;
	a[root].l=build(ml,index-1,pl+1,pl+num);
	a[root].r=build(index+1,mr,pl+num+1,pr);
	return root;
}
void bfs(int root){
	queue<int> ans;
	vector<int> res;
	ans.push(root);
	while(!ans.empty()){
		int t=ans.front();ans.pop();	
		if(t==0)break;//发生了错误 
		res.push_back(t); 
		if(a[t].r!=0)ans.push(a[t].r);
		if(a[t].l!=0)ans.push(a[t].l);
	}
	cout<<res[0];
	for(int i=1;i<res.size();i++)cout<<" "<<res[i];
}
int main(){
	cin>>n;
	for(int i=1;i<=n;i++)cin>>mid[i];
	for(int i=1;i<=n;i++)cin>>pre[i];
	int root=build(1,n,1,n);
	bfs(root);	
	return 0;
}

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  • 0
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值