hdu1503(DP)

Advanced Fruits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1289    Accepted Submission(s): 630
Special Judge


Problem Description
The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new fruit emerges that tastes like a mixture between both of them.
A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property.

A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example.

Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names.
 

Input
Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters.

Input is terminated by end of file.
 

Output
For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable.
 

Sample Input
  
  
apple peach ananas banana pear peach
 

Sample Output
  
  
appleach bananas pearch
 

Source
 

Recommend
linle
 
此题要找互不重叠的最长公共部分,可以不连续,可以有多个。
dp[i][j]表示str1[0-i]与str2[0-j]的最长公共子串
belong[i][j]有三种取值,分别表示其属于str1,str2 ,或二者共有
每来一对字符str1[i]与str2[j],看其是否相等:
             若相等,dp[i][j]=dp[i-1][j-1]+1,belong[i][j]=0(表示属于公共部分);
             若不想等,则看那边的共用部分长:
                               若dp[i-1][j]>dp[i][j-1],说明str2[j]可用与str1[0-i-1]中的公共部分长,str1[i]的单独输出,belong[i][j]=-1;
                               若dp[i-1][j]<dp[i][j-1],说明str1[i]可用与str2[0-j-1]中的公共部分长,str2[j]的单独输出,belong[i][j]=1.
然后倒过来依据belong[i][j]递归输出,之所以倒过来是因为先输哪一个(len1+len2各种不确定),但一定知道最后比输str1[len1-1],str2[len2-1]中的一个,进而知道倒数第二个应输哪一个。
 
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;

const int MAXN=100+10;
char str1[MAXN],str2[MAXN];
int dp[MAXN][MAXN];
int belong[MAXN][MAXN];
int len1,len2;

void LCS()
{
	int i,j,ans;
	len1=strlen(str1);
	len2=strlen(str2);

	memset(dp,0,sizeof(dp));
	memset(belong,0,sizeof(belong));
//	ans=-1;
	for(i=1;i<=len1;i++)
		belong[i][0]=-1;//这个时刻str1[i]要单独输
	for(i=1;i<=len2;i++)
		belong[0][i]=1;//这个时刻str2[i]要单独输
	//看看选哪一个可是公共部分最短
	for(i=1;i<=len1;i++)
	{
		for(j=1;j<=len2;j++)
		{
			if(str1[i-1]==str2[j-1])
			{
				dp[i][j]=dp[i-1][j-1]+1;
				belong[i][j]=0;//表示这个时刻属公共部分
			}
			else if(dp[i][j-1]>dp[i-1][j])
			{
				dp[i][j]=dp[i][j-1];
				belong[i][j]=1;//这个时刻str2[j]要单独输
			}
			else
			{
				dp[i][j]=dp[i-1][j];
				belong[i][j]=-1;//这个时刻str1[i]要单独输
			}
			//if(ans<dp[i][j])ans=dp[i][j];
		}
	}
//	printf("LCS=%d\n",ans);
}
/*
void Print()
{
	int i=1,j=1;
	while(i<=len1||j<=len2)
	{
		if(belong[i][j]==0)
		{
			printf("%c",str1[i-1]);
			i++,j++;
		}
		else if(belong[i][j]==-1)
		{
			printf("%c",str1[i-1]);
				i++;
		}
		else 
		{
			printf("%c",str2[j-1]);
			j++;
		}
	//	i++,j++;

	}
	printf("\n");
}*/

void Print(int tlen1,int tlen2)
{
	if(0==tlen1&&0==tlen2)
		return;
	else if(belong[tlen1][tlen2]==0)
	{
		Print(tlen1-1,tlen2-1);
		printf("%c",str1[tlen1-1]);
	}
	else if(belong[tlen1][tlen2]==-1)
	{
		Print(tlen1-1,tlen2);
		printf("%c",str1[tlen1-1]);
	}
	if(belong[tlen1][tlen2]==1)
	{
		Print(tlen1,tlen2-1);
		printf("%c",str2[tlen2-1]);
	}
}

int main()
{
	while(~scanf("%s%s",str1,str2))
	{
		LCS();
		Print(len1,len2);
		printf("\n");
	}
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值