The Famous ICPC Team Again
Time Limit: 30000/15000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 696 Accepted Submission(s): 335
Problem Description
When Mr. B, Mr. G and Mr. M were preparing for the 2012 ACM-ICPC World Final Contest, Mr. B had collected a large set of contest problems for their daily training. When they decided to take training, Mr. B would choose one of them from the problem set. All the problems in the problem set had been sorted by their time of publish. Each time Prof. S, their coach, would tell them to choose one problem published within a particular time interval. That is to say, if problems had been sorted in a line, each time they would choose one of them from a specified segment of the line.
Moreover, when collecting the problems, Mr. B had also known an estimation of each problem’s difficultness. When he was asked to choose a problem, if he chose the easiest one, Mr. G would complain that “Hey, what a trivial problem!”; if he chose the hardest one, Mr. M would grumble that it took too much time to finish it. To address this dilemma, Mr. B decided to take the one with the medium difficulty. Therefore, he needed a way to know the median number in the given interval of the sequence.
Moreover, when collecting the problems, Mr. B had also known an estimation of each problem’s difficultness. When he was asked to choose a problem, if he chose the easiest one, Mr. G would complain that “Hey, what a trivial problem!”; if he chose the hardest one, Mr. M would grumble that it took too much time to finish it. To address this dilemma, Mr. B decided to take the one with the medium difficulty. Therefore, he needed a way to know the median number in the given interval of the sequence.
Input
For each test case, the first line contains a single integer n (1 <= n <= 100,000) indicating the total number of problems. The second line contains n integers xi (0 <= xi <= 1,000,000,000), separated by single space, denoting the difficultness of each problem, already sorted by publish time. The next line contains a single integer m (1 <= m <= 100,000), specifying number of queries. Then m lines follow, each line contains a pair of integers, A and B (1 <= A <= B <= n), denoting that Mr. B needed to choose a problem between positions A and B (inclusively, positions are counted from 1). It is guaranteed that the number of items between A and B is odd.
Output
For each query, output a single line containing an integer that denotes the difficultness of the problem that Mr. B should choose.
Sample Input
5 5 3 2 4 1 3 1 3 2 4 3 5 5 10 6 4 8 2 3 1 3 2 4 3 5
Sample Output
Case 1: 3 3 2 Case 2: 6 6 4
Source
本题同poj2106基本上使用木一样的,可以直接修改一下上题的源代码。都是划分树最基本的模板题。http://blog.csdn.net/xj2419174554/article/details/10638695
#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
const int MAXN=100000+100;
const int MAXPOW=20;//MAXPOW依据MAXN定大小
int tree[MAXPOW][MAXN];//tree[dep][i]表示第dep层第i个位置的值
int sorted[MAXN];//已经排序的数
int toleft[MAXPOW][MAXN];//toleft[dep][i]表示第dep层从1到i进入左边元素的个数
//构建深度为dep、区间为[l,r]的划分树
//时间复杂度为O(N*log(N))
void build(int l,int r,int dep)
{
int i;
if(l==r)return;
int mid=(l+r)>>1;
int same=mid-l+1;//表示等于中间元素而且被进入左边的元素个数
for(i=l;i<=r;i++)
if(tree[dep][i]<sorted[mid])
same--;
int lpos=l;
int rpos=mid+1;
for(i=l;i<=r;i++)
{
if(tree[dep][i]<sorted[mid])//比中间的元素小,进入左边
tree[dep+1][lpos++]=tree[dep][i];
else if(tree[dep][i]==sorted[mid]&&same>0)
{
tree[dep+1][lpos++]=tree[dep][i];
same--;
}
else //比中间的元素大,进入右边
tree[dep+1][rpos++]=tree[dep][i];
toleft[dep][i]=toleft[dep][l-1]+lpos-l;//从1到i放左边的元素个数
}
build(l,mid,dep+1);
build(mid+1,r,dep+1);
}
//查询小区间[l,r]内的第k大的元素,[L,R]是覆盖小区间的大区间
//时间复杂度为O(log(N))
int query(int L,int R,int l,int r,int dep,int k)
{
if(l==r)return tree[dep][l];
int mid=(L+R)>>1;
int cnt=toleft[dep][r]-toleft[dep][l-1];//[l,r]中位于左边的元素个数
if(cnt>=k)//进入左子树查询
{
//修改小区间的l=L+要查询的区间前进入左边的元素个数
int newl=L+toleft[dep][l-1]-toleft[dep][L-1];
//r=newl+查询区间会被放在左边的元素个数
int newr=newl+cnt-1;
return query(L,mid,newl,newr,dep+1,k);
}
else//进入右子树查询
{
//修改小区间的r=r+要查询的区间后进入左边的元素个数
int newr=r+toleft[dep][R]-toleft[dep][r];
//l=r-要查询的区间进入右边的元素个数
int newl=newr-(r-l-cnt);
return query(mid+1,R,newl,newr,dep+1,k-cnt);
}
}
int main()
{
int n,m,i,l,r,k,tag=1;
while(~scanf("%d",&n))
{
memset(tree,0,sizeof(tree));//这个必须
for(i=1;i<=n;i++)//从1开始
{
scanf("%d",&tree[0][i]);
sorted[i]=tree[0][i];
}
sort(sorted+1,sorted+n+1);
build(1,n,0);
scanf("%d",&m);
printf("Case %d:\n",tag++);
while(m--)
{
scanf("%d%d",&l,&r);
k=(r-l)/2+1;
//k=(l+r)>>1;
// printf("\n*******************k=%d\n",k);
printf("%d\n",query(1,n,l,r,0,k));
}
}
return 0;
}