poj1269(计算几何+直线位置)

Intersecting Lines
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 9432 Accepted: 4235

Description

We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect.
Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000.

Input

The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4. Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).

Output

There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point. If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read "END OF OUTPUT".

Sample Input

5
0 0 4 4 0 4 4 0
5 0 7 6 1 0 2 3
5 0 7 6 3 -6 4 -3
2 0 2 27 1 5 18 5
0 3 4 0 1 2 2 5

Sample Output

INTERSECTING LINES OUTPUT
POINT 2.00 2.00
NONE
LINE
POINT 2.00 5.00
POINT 1.07 2.20
END OF OUTPUT

Source

Mid-Atlantic 1996

 

         本题要判断两直线的关系,若相交求交点。合理控制一下精度。在计算机中应该尽可能避开特殊情况(本题为斜率不存在)的判断。

如何判断是否平行

       由向量可以判断出两直线是否平行。如果两直线平行,那么向量p1p2、p3p4也是平等的。即((p1.x-p2.x)*(p3.y-p4.y)-(p1.y-p2.y)*(p3.x-p4.x))==0说明向量平等。

如何判断是否同线?

       由叉积的原理知道如果p1,p2,p3共线的话那么(p2-p1)X(p3-p1)=0。因此如果p1,p2,p3共线,p1,p2,p4共线,那么两条直线共线。求叉积,叉积为0说明共线。

如何求出交点?

      这里也用到叉积的原理。假设交点为p0(x0,y0)。则有:

                    (p1-p0)X(p2-p0)=0

                    (p3-p0)X(p2-p0)=0

        此公式可避开斜率不存在的判断。

#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;

const double eps=1e-8;

double IsParallel(double x1,double y1,double x2,double y2,double x3,double y3,double x4,double y4)
{
	return (y2-y1)*(x4-x3)-(y4-y3)*(x2-x1);
}

double XMulti(double x1,double y1,double x2,double y2,double x3,double y3)
{
	return (x2-x1)*(y3-y1)-(x3-x1)*(y2-y1);
}

int main ()
{
	int cas;
	double x1,y1,x2,y2,x3,y3,x4,y4,Cro_x,Cro_y; 
	cin>>cas;
	printf("INTERSECTING LINES OUTPUT\n");
	while(cas--)
	{
		scanf("%lf%lf%lf%lf%lf%lf%lf%lf",&x1,&y1,&x2,&y2,&x3,&y3,&x4,&y4);
		if(fabs(IsParallel(x1,y1,x2,y2,x3,y3,x4,y4))<eps)
		{
			if(fabs(XMulti(x1,y1,x2,y2,x3,y3))<eps)
				printf("LINE\n");
			else printf("NONE\n");
		}
		else 
		{
			if(fabs(1.0*(x1-x2))<eps)
			{
				Cro_x=x1;
				Cro_y=(y4-y3)/(x4-x3)*(Cro_x-x3)+y3;
			}
			else if(fabs(1.0*(x3-x4))<eps)
			{
				Cro_x=x3;
				Cro_y=(y2-y1)/(x2-x1)*(Cro_x-x1)+y1;
			}
			else
			{
				Cro_x=((y1-y3)*(x2-x1)*(x4-x3)+x3*(y4-y3)*(x2-x1)-(x4-x3)*(y2-y1)*x1)/((y4-y3)*(x2-x1)-(y2-y1)*(x4-x3));
				Cro_y=(y4-y3)/(x4-x3)*(Cro_x-x3)+y3;
			}
			printf("POINT %0.2lf %0.2lf\n",Cro_x,Cro_y);
		}
	}
	printf("END OF OUTPUT\n");
	system("pause");
	return 0;
}


 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值