HDU1250(大数相加)

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4998    Accepted Submission(s): 1691


Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
 


 

Input
Each line will contain an integers. Process to end of file.
 


 

Output
For each case, output the result in a line.
 


 

Sample Input
  
  
100
 


 

Sample Output
  
  
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.

 

///运用数组存储固定邻接位数

#include<iostream>
#include<iomanip>
using namespace std;
struct
{
 int link[600];
 int num;
}a[10010];
int main()
{
 int n,i,j,temp;
 a[1].link[a[1].num++]=1;
 a[2].link[a[2].num++]=1;
 a[3].link[a[3].num++]=1;
 a[4].link[a[4].num++]=1;
 for(i=5;i<=10000;i++)
 {
  temp=0;
  for(j=0;j<=a[i-1].num-1;j++)
  {
   a[i].link[j]=a[i-1].link[j]+a[i-2].link[j]+a[i-3].link[j]+a[i-4].link[j]+temp;
   temp=a[i].link[j]/10000;
   a[i].link[j]=a[i].link[j]%10000;
  }
  a[i].num=a[i-1].num;
  if(temp>0)
  {
   a[i].link[j]=temp;
   a[i].num++;
  }
 }
 while(cin>>n)
 {
  j=a[n].num-1;
  cout<<a[n].link[j];
  for(j=a[n].num-2;j>=0;j--)
  {
   printf("%04d",a[n].link[j]);  
  }
  cout<<endl; 
 }
 return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值