hdu1133(卡特兰数)

Buy the Ticket

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3864    Accepted Submission(s): 1620


Problem Description
The "Harry Potter and the Goblet of Fire" will be on show in the next few days. As a crazy fan of Harry Potter, you will go to the cinema and have the first sight, won’t you?

Suppose the cinema only has one ticket-office and the price for per-ticket is 50 dollars. The queue for buying the tickets is consisted of m + n persons (m persons each only has the 50-dollar bill and n persons each only has the 100-dollar bill).

Now the problem for you is to calculate the number of different ways of the queue that the buying process won't be stopped from the first person till the last person.
Note: initially the ticket-office has no money.

The buying process will be stopped on the occasion that the ticket-office has no 50-dollar bill but the first person of the queue only has the 100-dollar bill.
 

Input
The input file contains several test cases. Each test case is made up of two integer numbers: m and n. It is terminated by m = n = 0. Otherwise, m, n <=100.
 

Output
For each test case, first print the test number (counting from 1) in one line, then output the number of different ways in another line.
 

Sample Input
  
  
3 0 3 1 3 3 0 0
 

Sample Output
  
  
Test #1: 6 Test #2: 18 Test #3: 180
 

Author
HUANG, Ninghai
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:   1267  1297  1130  1207  2100 
         本题是个变形的卡特兰数。
http://daybreakcx.is-programmer.com/posts/17315.html有篇大牛关于卡特兰数的讲解,推荐一看!
import java.math.BigInteger;
import java.util.Scanner;


public class hdu1133{
	
	static BigInteger []h=new BigInteger[210];
	static void GetOder()
	{	
		h[0]=new BigInteger("1");
		BigInteger tmp=new BigInteger("0");
		for(int i=1;i<=200;i++)
		{
			tmp=tmp.add(new BigInteger("1"));
			h[i]=new BigInteger("1");
			h[i]=h[i-1].multiply(tmp);
		}
	}
	
	public static void main(String[] str)
	{
		Scanner input=new Scanner(System.in);
		GetOder();
		int n,m;
		int tag=0;
		while(input.hasNext())
		{
			m=input.nextInt();
			n=input.nextInt();
			if(0==n&&0==m)break;
			System.out.println("Test #"+(++tag)+":");
			if(n>m)
				System.out.println("0");
			else if(n!=0)
			{
			    BigInteger ans=new BigInteger("0");
			    ans=ans.add(h[n+m]);
			    ans=ans.divide(h[m]);
			    ans=ans.divide(h[n]);
			    
			    BigInteger ret=new BigInteger("0");
			    ret=ret.add(h[n+m]);
			    ret=ret.divide(h[m+1]);
			    ret=ret.divide(h[n-1]);
			    
			    ans=ans.subtract(ret);
			    ans=ans.multiply(h[n]);
			    ans=ans.multiply(h[m]);
			    
			     System.out.println(ans);
			}
			else 
			{
				System.out.println(h[m]);
			}
			
		}
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值