hdu2473(并查集)

Junk-Mail Filter

Time Limit: 15000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4855    Accepted Submission(s): 1542


Problem Description
Recognizing junk mails is a tough task. The method used here consists of two steps:
1) Extract the common characteristics from the incoming email.
2) Use a filter matching the set of common characteristics extracted to determine whether the email is a spam.

We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations:

a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so
relationships (other than the one between X and Y) need to be created if they are not present at the moment.

b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph.

Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N.
Please help us keep track of any necessary information to solve our problem.
 

Input
There are multiple test cases in the input file.
Each test case starts with two integers, N and M (1 ≤ N ≤ 10 5 , 1 ≤ M ≤ 10 6), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above.
Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program.
 

Output
For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below.
 

Sample Input
  
  
5 6 M 0 1 M 1 2 M 1 3 S 1 M 1 2 S 3 3 1 M 1 2 0 0
 

Sample Output
  
  
Case #1: 3 Case #2: 2
 
 
本题是个比较容易想到的并查集题目,不过题目要求的不仅有合并操作还有删除操作,删除操作并不是并查集的基本操作,所以应该在删除操作上做文章。
设置结构体数组Ele[a]存放节点信息,其中Ele[a].vir_par是虚拟结点,Ele[a].par时父亲结点,每进行依次删除操作就更新Ele[a].vir_par,并将其与其在同一子集上的元素分开,最终不同父亲节点的个数即为答案。
#include<iostream>
#include<cstring>
using namespace std;

const int MAX=1100000+100;
struct node
{
	int vir_par,par;
}Ele[MAX];
int hash[MAX];
int extra;

int Get_par(int a)
//查找a的父亲节点并压缩路径
{
	if(Ele[a].par==a)
		return Ele[a].par;
	Ele[a].par=Get_par(Ele[a].par);
	return Ele[a].par;
}

void Merge(int a,int b)
//合并a,b
{
	int pa,pb;
	pa=Get_par(a);
	pb=Get_par(b);
	if(pa==pb)
		return;
	Ele[pa].par=pb;
}


void Delete(int a)
//删除与a结点有关的边
{
	Ele[a].vir_par=extra;
	Ele[Ele[a].vir_par].par=extra;
	extra++;
}


int main()
{
	int n,m,i,count,a,b,tmp,flag=1;
	char cmd[10];
	while(scanf("%d%d",&n,&m))
	{
		if(0==n&&0==m)
			break;
		for(i=0;i<n;i++)
		{
			Ele[i].par=Ele[i].vir_par=i;
		}
		extra=n;
		while(m--)
		{
			scanf("%s",cmd);
			if(cmd[0]=='M')
			{
				scanf("%d%d",&a,&b);
				Merge(Ele[a].vir_par,Ele[b].vir_par);
			}
			else 
			{
				scanf("%d",&a);
				Delete(a);
			}
		}
		count=0;
		memset(hash,0,sizeof(int)*extra);
		for(i=0;i<n;i++)
		{
			tmp=Get_par(Ele[i].vir_par);
		//	cout<<Ele[i].vir_par<<"   "<<tmp<<endl;
			if(hash[tmp]==0)
				hash[tmp]++,count++;
		}

		printf("Case #%d: %d\n",flag++,count);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值