hdu3466(01背包)

Proud Merchants

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 1762    Accepted Submission(s): 709


Problem Description
Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?

 

Input
There are several test cases in the input.

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.

The input terminates by end of file marker.

 

Output
For each test case, output one integer, indicating maximum value iSea could get.

 

Sample Input
  
  
2 10 10 15 10 5 10 5 3 10 5 10 5 3 5 6 2 7 3
 

Sample Output
  
  
5 11
 
本题是个0-1背包问题,不同之处是有限制条件Qi
需要对item[i]按item[i].Q-item[i].P从大到小的顺序排序,从而保证dp[i]是费用小于等于i的最大价值
#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;

const int MAX=500+10;
struct node
{
	int P,Q,V;
}item[MAX];
int dp[5000+10];

int Max(int a,int b)
{
	return a<b?b:a;
}

bool cmp(node a,node b)
{
	return a.Q-a.P<b.Q-b.P;
}

int main()
{
	int i,n,m,j;
	while(~scanf("%d%d",&n,&m))
	{
		for(i=1;i<=n;i++)
			scanf("%d%d%d",&item[i].P,&item[i].Q,&item[i].V);
		memset(dp,0,sizeof(dp));
		sort(item+1,item+1+n,cmp);

		for(i=1;i<=n;i++)
		{
			for(j=m;j>=item[i].Q;j--)
				dp[j]=Max(dp[j],dp[j-item[i].P]+item[i].V);
		}
		printf("%d\n",dp[m]);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值