hdu4632(DP)

Palindrome subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65535 K (Java/Others)
Total Submission(s): 495    Accepted Submission(s): 172


Problem Description
In mathematics, a subsequence is a sequence that can be derived from another sequence by deleting some elements without changing the order of the remaining elements. For example, the sequence <A, B, D> is a subsequence of <A, B, C, D, E, F>.
(http://en.wikipedia.org/wiki/Subsequence)

Given a string S, your task is to find out how many different subsequence of S is palindrome. Note that for any two subsequence X = <S x1, S x2, ..., S xk> and Y = <S y1, S y2, ..., S yk> , if there exist an integer i (1<=i<=k) such that xi != yi, the subsequence X and Y should be consider different even if S xi = S yi. Also two subsequences with different length should be considered different.
 

Input
The first line contains only one integer T (T<=50), which is the number of test cases. Each test case contains a string S, the length of S is not greater than 1000 and only contains lowercase letters.
 

Output
For each test case, output the case number first, then output the number of different subsequence of the given string, the answer should be module 10007.
 

Sample Input
  
  
4 a aaaaa goodafternooneveryone welcometoooxxourproblems
 

Sample Output
  
  
Case 1: 1 Case 2: 31 Case 3: 421 Case 4: 960
 

Source
 
比赛的时候一直试图用AC自动机或字典树做,走不通;此题关键在于找到状态转移方程,有了状态转移方程就可以递归的做,在数据量比较大时可以转化成非递归的
状态转移方程为dp[i][j]=dp[i+1][j]+dp[i][j-1],其中dp[i+1][j]与dp[i][j-1]的公共部分为dp[i+1][j-1]
若str[i]=str[j],公共部分的两头可以加入str[i]和str[j],且单独的str[i],str[j]也可以组成一个长度为二的回文,所以可以dp[i][j]=dp[i+1][j]+dp[i][j-1]+1
若str[i]=str[j],应删除公共部分dp[i+1][j-1],dp[i][j]=dp[i+1][j]+dp[i][j-1]-dp[i+1][j-1]
注意一些边界条件,注意递归的优化
 
 
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

const int MAX=1000+10;
const int MOD=10007;
char str[MAX];
int dp[MAX][MAX];


int DP(int l,int r)
{
	if(l>r)
		return 0;
	else if(l==r)
		return dp[l][r]=1;
	else if(dp[l][r]!=-1)
		return dp[l][r];
	dp[l][r]=(DP(l+1,r)+DP(l,r-1))%MOD;
	if(str[l]==str[r])
		dp[l][r]++;
	else 
	{
		dp[l][r]-=DP(l+1,r-1);//此时可能出现负数,注意负数的取模
		if(dp[l][r]<0)
			dp[l][r]+=MOD;
	}
	return dp[l][r]%MOD;

}

int main()
{
	int cas,len,tag=1;
	cin>>cas;
	while(cas--)
	{
		scanf("%s",str);
		memset(dp,-1,sizeof(dp));
		len=strlen(str);
		printf("Case %d: %d\n",tag++,DP(0,len-1)%MOD);
	}
	return 0;
}

 
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值