hdu4296(贪心)

Buildings

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1274    Accepted Submission(s): 552


Problem Description
  Have you ever heard the story of Blue.Mary, the great civil engineer? Unlike Mr. Wolowitz, Dr. Blue.Mary has accomplished many great projects, one of which is the Guanghua Building.
  The public opinion is that Guanghua Building is nothing more than one of hundreds of modern skyscrapers recently built in Shanghai, and sadly, they are all wrong. Blue.Mary the great civil engineer had try a completely new evolutionary building method in project of Guanghua Building. That is, to build all the floors at first, then stack them up forming a complete building.
  Believe it or not, he did it (in secret manner). Now you are face the same problem Blue.Mary once stuck in: Place floors in a good way.
  Each floor has its own weight w i and strength s i. When floors are stacked up, each floor has PDV(Potential Damage Value) equal to (Σw j)-s i, where (Σw j) stands for sum of weight of all floors above.
  Blue.Mary, the great civil engineer, would like to minimize PDV of the whole building, denoted as the largest PDV of all floors.
  Now, it’s up to you to calculate this value.
 

Input
  There’re several test cases.
  In each test case, in the first line is a single integer N (1 <= N <= 10 5) denoting the number of building’s floors. The following N lines specify the floors. Each of them contains two integers w i and s i (0 <= w i, s i <= 100000) separated by single spaces.
  Please process until EOF (End Of File).
 

Output
  For each test case, your program should output a single integer in a single line - the minimal PDV of the whole building.
  If no floor would be damaged in a optimal configuration (that is, minimal PDV is non-positive) you should output 0.
 

Sample Input
  
  
3 10 6 2 3 5 4 2 2 2 2 2 3 10 3 2 5 3 3
 

Sample Output
  
  
1 0 2
 

Source
 
本题一层建筑的伤害值等于它上面的所有累加减它的s,即(∑wj)-si,其中j>i;本题要求最大伤害值的最小值,是个很明显的贪心问题。
对于贪心问题,我是先假设某个贪心策略,然后进行数据验证,若验证错误则修改贪心策略,可以枚举贪心策略;若验证正确,则寻求证明。
本题的贪心策略是
证明如下:
      若已经在上面建了一些,(∑w)=sum,当前考虑再建i,j
      若先建i,i的伤害值为sum-si,j的伤害值为sum+wi-sj;若先建j,j的伤害值为sum-sj,i的伤害值为sum+wj-si
      若sum+wi-sj>sum+wj-si,则wi+si>wj+sj此时应先建j(sum-si<sum+wj-si,sum+wi-sj>sum-sj,假设sum+wi-sj>sum+wj-si,则sum+wi-sj>sum-si,可以保证j的伤害值比j大),从而只需将j,所以将wi+si从小到大排序,每次选择wi+si小的,这样的得到的最大伤害值最小。
 
 
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;

const int MAX=100000+10;
struct node
{
	int w,s;
}Floor[MAX];

bool cmp(node a,node b)
{
	return a.w+a.s<b.w+b.s;
}

int main()
{
	int n,i;
	__int64 tmp,ans;
	while(~scanf("%d",&n))
	{
		for(i=0;i<n;i++)
			scanf("%d%d",&Floor[i].w,&Floor[i].s);

		sort(Floor,Floor+n,cmp);
		ans=0;tmp=0;
		for(i=0;i<n;i++)
		{
			if(tmp-Floor[i].s>ans)
				ans=tmp-Floor[i].s;
			tmp+=Floor[i].w;
		}

		printf("%I64d\n",ans);
	}
	return 0;
}

 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值