HDU 4296 Buildings(贪心)


Buildings

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)



Problem Description
  Have you ever heard the story of Blue.Mary, the great civil engineer? Unlike Mr. Wolowitz, Dr. Blue.Mary has accomplished many great projects, one of which is the Guanghua Building.
  The public opinion is that Guanghua Building is nothing more than one of hundreds of modern skyscrapers recently built in Shanghai, and sadly, they are all wrong. Blue.Mary the great civil engineer had try a completely new evolutionary building method in project of Guanghua Building. That is, to build all the floors at first, then stack them up forming a complete building.
  Believe it or not, he did it (in secret manner). Now you are face the same problem Blue.Mary once stuck in: Place floors in a good way.
  Each floor has its own weight w i and strength s i. When floors are stacked up, each floor has PDV(Potential Damage Value) equal to (Σw j)-s i, where (Σw j) stands for sum of weight of all floors above.
  Blue.Mary, the great civil engineer, would like to minimize PDV of the whole building, denoted as the largest PDV of all floors.
  Now, it’s up to you to calculate this value.
 

Input
  There’re several test cases.
  In each test case, in the first line is a single integer N (1 <= N <= 10 5) denoting the number of building’s floors. The following N lines specify the floors. Each of them contains two integers w i and s i (0 <= w i, s i <= 100000) separated by single spaces.
  Please process until EOF (End Of File).
 

Output
  For each test case, your program should output a single integer in a single line - the minimal PDV of the whole building.
  If no floor would be damaged in a optimal configuration (that is, minimal PDV is non-positive) you should output 0.
 

Sample Input
  
  
3 10 6 2 3 5 4 2 2 2 2 2 3 10 3 2 5 3 3
 

Sample Output
  
  
1 0 2
 

Source


题目大意:

输入一个整数n,代表有n块砖块,再输入n行,每行两个整数w,s,分别代表砖头的重量和强度,当叠在砖块上的重量之和大于它的强度时,就会有一个亏损,亏损值为:此砖块上面的总质量-此砖块的强度值,当小于0时,为0,现在已所有砖块中最大的亏损值来代表整个建筑的亏损值,输出这个亏损值。

解题思路:

设w,s数组代表重量和强度,设一块砖块放在上面为w[i],s[i],另一块放在下面为w[j],s[j],亏损值C1为w[i]-s[j],第二次倒转顺序,则亏损值C2为w[j]-s[i];现在主要的问题是排序,如果前者优于后者,则要是PDV最小,即w[i]-s[j]<w[j]-s[i]   ==>  w[i]+s[i]<w[j]+s[j].所以砖块按照和的从小到大放(最上面放和最小的,最下面放和最大的)。


代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#define maxN 100010

using namespace std;

int n;
long long sumWeight[maxN];

struct node{
    int w,s;
    node(int w0=0,int s0=0){
        w=w0,s=s0;
    }
}fl[maxN];

bool cmp(node a,node b){
    return a.w+a.s<b.w+b.s;
}

int main(){
    long long maxCost=0;
    while(scanf("%d",&n)!=EOF){
        for(int i=0;i<n;i++){
            scanf("%d%d",&fl[i].w,&fl[i].s);
        }
        sort(fl,fl+n,cmp);
        sumWeight[0]=fl[0].w;
        maxCost=sumWeight[0]-fl[1].s;
        for(int i=1;i<n-1;i++){
            sumWeight[i]=sumWeight[i-1]+fl[i].w;
            if(sumWeight[i]-fl[i+1].s>maxCost){maxCost=sumWeight[i]-fl[i+1].s;}
        }
        if(maxCost>=0)printf("%I64d\n",maxCost);
        else printf("0\n");
    }
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值