hdu1276(多重背包)

Cash Machine
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 23771 Accepted: 8316

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 ... nN DN

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0

Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash.

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

Source

 
在给定每张面额及其数量的情况下求小于等于给定面额的最大面额数量。
若把本题的面额分别看做背包问题的物品的重量和价值,把给定的最大面额当做背包的载重量,求该背包所能装载的最大价值,只是一个典型的多重背包问题。再次亮出模板秒杀之。
 
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;

//多重背包的模板
int dp[100000+10];//是具体情况而定
struct node
{
	int num,weight,value;//分别代表每种物品的数量、重量、价值
}Good[15];//定义每个物品的结构体
int Max_weight;//背包的载重量

int max(int a,int b)
{
	return a<b?b:a;
}

void ZeroOnePack(int weight,int value,int lim)
//对应01背包的求法
{
    for(int i=lim;i>=weight;i--)
		dp[i]=max(dp[i],dp[i-weight]+value);
}

void CompletePack(int weight,int value,int lim)
//对应完全背包的求法
{
    for(int i=weight;i<=lim;i++)
		dp[i]=max(dp[i],dp[i-weight]+value);
}

void MultiplePack(int weight,int value,int amount,int lim)
//选定物品后的多重背包的求法
{
    if(weight*amount>=lim)CompletePack(weight,value,lim);
    else
    {
        for(int k=1;k<amount;)
        {
            ZeroOnePack(k*weight,k*value,lim);
            amount-=k;
            k<<=1;
        }
        ZeroOnePack(amount*weight,amount*value,lim);
    }
}

void Solve(int n)
//解决物品种类数为n的多重背包问题求法
{
	memset(dp,0,sizeof(dp));
	for(int i=1;i<=n;i++)
		MultiplePack(Good[i].weight,Good[i].value,Good[i].num,Max_weight);
}

int main()
{
	int n,i;
	while(~scanf("%d",&Max_weight))
	{
		scanf("%d",&n);
		for(i=1;i<=n;i++)
		{
			scanf("%d%d",&Good[i].num,&Good[i].weight);
			Good[i].value=Good[i].weight;
		}
		Solve(n);
		printf("%d\n",dp[Max_weight]);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值