原题链接
Problem Description
朝为田舍郎,暮登天子堂。秋实大哥从小就怀抱有远大的理想,所以他开了一家快餐店。
秋实大哥根据菜的口感,给每一道菜一个唯一的CID,同时对于前来的客人,根据他们的口味喜好,秋实大哥会给每一个客人一个PID。
对于一个标号为PID的客人,他对标号为CID的菜的喜爱程度为PID∧CID(∧表示按位异或),该值越大表示越喜欢。
秋实大哥实在太忙了,现在他需要你来帮忙照看一下他的店铺。
Input
第一行包含一个整数n,表示秋实大哥的餐馆内现在有n道菜。
接下来一行包含n个整数,分别表示每一道菜的CID。
接下来一行包含一个整数m,表示接下来发生了m件事。
接下来的m行,每一行为以下两种事件之一:
0 c : 表示秋实大哥最新研制出一道标号为c的菜
1 p : 表示来了一位标号为p的客人,请你在已有的菜中找出一道他最喜爱的菜
1≤n,m≤100000,0≤PID,CID≤1000000。
Output
对于每一个1 p事件输出一个整数,表示该客人最喜欢的菜的标号。
Sample Input
1
1
3
1 1
0 2
1 1
Sample Output
1
2
解题思路
用贪心的思想,首先对每一项任务,根据惩罚从从大到小排序,惩罚相同的截止日小的靠前排,这样我们就有了一个任务序列。在这个序列里从前往后依次安排任务,从每项任务的截止日开始往前找空位即可,如发现无法找到,就在最终结果中加上这项任务的惩罚。
AC代码
#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;
typedef long long LL;
class Trie
{
public:
Trie *next[2];
Trie()
{
next[0]=next[1]=NULL;
}
};
Trie *root;
void Insert(LL n) //按照字典树的路径逐步推进
{
Trie *p = root;
for(int i=31;i>=0;i--)
{
int id = (n >> i) & 1;
if(p->next[id] == NULL)
p->next[id] = new Trie();
p = p->next[id];
}
}
void Delete(Trie *T) //递归删树
{
if(T == NULL) return;
for(int i=0;i<2;i++)
if(T->next[i] != NULL)
Delete(T->next[i]);
}
int Match(int m) //首先取反,然后尽量往匹配的方向走
{
m = ~m;
int ans = 0;
Trie *p = root;
for(int i=31;i>=0;i--)
{
ans <<= 1;
int bit = (m >> i) & 1;
if(bit)
{
if(p->next[1])
{
p = p->next[1];
ans++;
}
else
{
p = p->next[0];
}
}
else
{
if(p->next[0])
{
p = p->next[0];
}
else
{
p = p->next[1];
ans++;
}
}
}
return ans;
}
int main()
{
int tt ;
int n,m;
root = new Trie();
scanf("%d",&n);
for(int i=0;i<n;i++)
{
int val;
scanf("%d",&val);
Insert(val);
}
cin>>m;
while(m--)
{
int val;
scanf("%d%d",&tt,&val);
if(tt==0) Insert(val);
else printf("%d\n",Match(val));
}
Delete(root);
return 0;
}