简单题练习——翻转单词顺序

题目描述:
JOBDU最近来了一个新员工Fish,每天早晨总是会拿着一本英文杂志,写些句子在本子上。同事Cat对Fish写的内容颇感兴趣,有一天他向Fish借来翻看,但却读不懂它的意思。例如,“student. a am I”。后来才意识到,这家伙原来把句子单词的顺序翻转了,正确的句子应该是“I am a student.”。Cat对一一的翻转这些单词顺序可不在行,你能帮助他么?
输入:
每个测试案例为一行,表示一句英文句子。
我们保证一个句子的单词数不会超过600,每个单词的长度也不会超过30。但是需要注意的是Fish是个不拘小节的人,有时候两个单词中间可能会有很多空格。为了方便起见,你可以认为一行的字符总数不会超过50000个,标点符号可以和普通字母一样处理。
输出:
对应每个测试案例,把翻转后的正确的句子单独输出一行。
样例输入:
student. a am I
I'm a Freshman and I like JOBDU!
样例输出:
I am a student.
JOBDU! like I and Freshman a I'm
 
  
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <string>
#include <map>
#include <cmath>
#include <assert.h>
#include <vector>
using namespace std;
char StrDic[50000];
 
void Reverse(char* str, int start, int end)
{
    while (start<end)
    {
        char temp = str[start];
        str[start] = str[end];
        str[end] = temp;
        start++;
        end--;
    }
}
 
int main()
{
    //freopen("in.txt","r",stdin);
    while (gets(StrDic))
    {
        int len = strlen(StrDic);
        Reverse(StrDic,0,len-1);
        int pos=0;
        int start,end;
        while (pos<len)
        {
            while (pos<len && StrDic[pos]==' ')
                pos++;
            start=pos;
            while (pos<len && StrDic[pos]!=' ')
                pos++;
            end=pos;
            if(start!=len)
                Reverse(StrDic,start,end-1);    
        }
        cout<<StrDic<<endl;
    }
    return 0;
}
/**************************************************************
    Problem: 1361
    User: xjbscut
    Language: C++
    Result: Accepted
    Time:60 ms
    Memory:1560 kb
****************************************************************/


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值