POJ1002 487-3279

487-3279
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 278264 Accepted: 49666

Description

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10. 

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows: 

A, B, and C map to 2 
D, E, and F map to 3 
G, H, and I map to 4 
J, K, and L map to 5 
M, N, and O map to 6 
P, R, and S map to 7 
T, U, and V map to 8 
W, X, and Y map to 9 

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010. 

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.) 

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number. 

Input

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters. 

Output

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line: 

No duplicates. 

Sample Input

12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

Sample Output

310-1010 2
487-3279 4
888-4567 3

Source

East Central North America 1999


http://poj.org/problem?id=1002

//题意输入N多少组电话  每个样例会根据一定的规则翻译成一个电话号码 ( - 不翻译) Q Z没有

// 输出次数大于 1 的电话 没有就输出那句话 

// 题目没有规定没说每个样例的长短吧那开多大的数组来装呢(诶 强迫症来了)  输入一个字符判断完再装的 好像操作不了

// 刚写这个道题 是不会 map 又不会 printf 所以很恶心做起来 还写了个 itoa函数 结果在POJ无限CE 后来查了一下 itoa是非标准的 C++函数, 后面看了一下输出 不用itoa 就过了


#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<algorithm>
using namespace std;
int vis[10000010];
char str[100];
char op[100];
char st[200];
int main()
{
    int n,i,k,j;
    scanf("%d",&n);
    memset(vis,0,sizeof(vis));
    for(i=0; i<n; i++)
    {
        scanf("%s",str);
        k=0;
        for(j=0; str[j]!='\0'; j++)
        {
            if(str[j]=='-') continue;
            if(str[j]>='A'&&str[j]<'Z')
            {
                if(str[j]>'Q')
                    op[k++]=(str[j]-'A'-1)/3+2+'0';
                else
                    op[k++]=(str[j]-'A')/3+2+'0';
            }
            else op[k++]=str[j];
        }
        op[k]='\0';         //这个很重要
        vis[atoi(op)]++;
    }
    //for(i=0; i<1000000; i++)
       // if(vis[i]>1)
       // {
          //  memset(st,'\0',sizeof(st));
          //  itoa(i,str,10);
           // int len=strlen(str);
           // len=7-len;
           // for(j=0; j<len; j++)
          //      st[j]='0';
          //  strcat(st,str);
          //  for(j=0; j<7; j++)
          //  {
          //      if(j==2)
           //         printf("%c-",str[j]);
             //   else printf("%c",str[j]);

        //    }
         //   printf(" %d\n",vis[i]);
        //}
    int flag=0;
    for(i=0; i<10000000; i++)
        if(vis[i]>1)
        {    flag=1;
           //itoa(i,str,10);
           // for(j=0; j<7; j++)
           // {
           //     if(j==2)
            //        printf("%c-",str[j]);
             //   else printf("%c",str[j]);

           // }
            printf("%03d-%04d",i/10000,i%10000);
            printf(" %d\n",vis[i]);
        }
        if(flag==0) printf("No duplicates.\n");
    return 0;
}

// 下面这个是大神 map的 

http://blog.csdn.net/niushuai666/article/details/6975760


#include <iostream>
#include <cstdio>
#include <cstring>
#include <map>

using namespace std;

int num[] =
{
	2, 2, 2,
	3, 3, 3,
	4, 4, 4,
	5, 5, 5,
	6, 6, 6,
	7, 0, 7, 7,
	8, 8, 8,
	9, 9, 9
};

map<int, int> s;
char buf[128];

int main()
{
	int t;
	scanf("%d", &t);
	bool flag = false;
	for(int i = 0; i < t; i++)
	{
		scanf("%s", &buf);
		int c = 0;
		for(int j = 0; buf[j]; j++)
		{
			if(isdigit(buf[j]))
				c = c * 10 + buf[j] - '0';
			else if(isalpha(buf[j]))
				c = c * 10 + num[ buf[j] - 'A' ];
		}
		s[c]++;                            //默认是0?;
	}
	for(map<int, int>::iterator it = s.begin(); it != s.end(); it++)
		if(it->second>1)             //找不到其他人这个写法,大神就是大神吧
		{
			flag = true;
			printf("%03d-%04d %d\n", it->first/10000,it->first%10000,it->second);
		}
	if(!flag)
		puts("No duplicates.");
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值