HDU3763 CD 二分

CD

Time Limit: 12000/6000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 760    Accepted Submission(s): 342


Problem Description
Jack and Jill have decided to sell some of their Compact Discs, while they still have some value. They have decided to sell one of each of the CD titles that they both own. How many CDs can Jack and Jill sell?

Neither Jack nor Jill owns more than one copy of each CD.
 

Input
The input consists of a sequence of test cases. The first line of each test case contains two non-negative integers N and M, each at most one million, specifying the number of CDs owned by Jack and by Jill, respectively. This line is followed by N lines listing the catalog numbers of the CDs owned by Jack in increasing order, and M more lines listing the catalog numbers of the CDs owned by Jill in increasing order. Each catalog number is a positive integer no greater than one billion. The input is terminated by a line containing two zeros. This last line is not a test case and should not be processed.
 

Output
For each test case, output a line containing one integer, the number of CDs that Jack and Jill both own.
 

Sample Input
  
  
3 3 1 2 3 1 2 4 0 0
 

Sample Output
  
  
2
 

Source

University of Waterloo Local Contest 2010.09.26 


http://acm.hdu.edu.cn/showproblem.php?pid=3763


//题意 找两个序列 相同数的个数

//两组数量最大都是一百万 可是CD序号可达10亿  但是我是了下开了个一千万的数组标记也水过了 

//此题有好多方法吧 用容器list vector map什么的都可以 反正装一百万个吗

//出题的本意是想你用二分吧   (题目要求按顺序输入) 


水过的

#include<stdio.h>
#include<string.h>

bool vis[10000005];

int main()
{
    int n,m,i,g;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(n+m==0) break;
        memset(vis,0,sizeof(vis));
        for(i=1; i<=n; i++)
        {
            scanf("%d",&g);
            vis[g]=1;
        }
        int ans=0;
        for(i=1; i<=m; i++)
        {
            scanf("%d",&g);
            if(vis[g]==1) ans++;
        }
        printf("%d\n",ans);
    }

    return 0;
}


     二分

  一百万 * log一百万 没多大

#include<stdio.h>
#define L 1000005
int a[L];
int n,m;
int binaryg(int k)
{
    int l=0,h=n-1,mid;
    while(l<=h)
    {
        mid=(l+h)/2;
        if(a[mid]==k) return 1;
        if(a[mid]>k) h=mid-1;
        else l=mid+1;
    }
    return 0;
}
int main()
{
    int i;
    while(~scanf("%d%d",&n,&m),n+m)
    {

        for(i=0; i<n; i++)
            scanf("%d",&a[i]);
        int ans=0;
        int h;
        for(i=0; i<m; i++)
        {
            scanf("%d",&h);
            ans+=binaryg(h);
        }
        printf("%d\n",ans);
    }
        return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值