HDU1350 Taxi Cab Scheme

Taxi Cab Scheme

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1126    Accepted Submission(s): 573


Problem Description
Running a taxi station is not all that simple. Apart from the obvious demand for a centralised coordination of the cabs in order to pick up the customers calling to get a cab as soon as possible, there is also a need to schedule all the taxi rides which have been booked in advance. Given a list of all booked taxi rides for the next day, you want to minimise the number of cabs needed to carry out all of the rides.

For the sake of simplicity, we model a city as a rectangular grid. An address in the city is denoted by two integers: the street and avenue number. The time needed to get from the address a, b to c, d by taxi is |a - c| + |b - d| minutes. A cab may carry out a booked ride if it is its first ride of the day, or if it can get to the source address of the new ride from its latest, at least one minute before the new ride’s scheduled departure. Note that some rides may end after midnight.
 

Input
On the first line of the input is a single positive integer N, telling the number of test scenarios to follow. Each scenario begins with a line containing an integer M, 0 < M < 500, being the number of booked taxi rides. The following M lines contain the rides. Each ride is described by a departure time on the format hh:mm (ranging from 00:00 to 23:59), two integers a b that are the coordinates of the source address and two integers c d that are the coordinates of the destination address. All coordinates are at least 0 and strictly smaller than 200. The booked rides in each scenario are sorted in order of increasing departure time.
 

Output
For each scenario, output one line containing the minimum number of cabs required to carry out all the booked taxi rides.
 

Sample Input
  
  
2 2 08:00 10 11 9 16 08:07 9 16 10 11 2 08:00 10 11 9 16 08:06 9 16 10 11
 

Sample Output
  
  
1 2

http://acm.split.hdu.edu.cn/showproblem.php?pid=1350

在某个时间一个人在一个坐标点需要去另一个坐标点 问最少需要几辆车才能满足所有人

一辆车从一个点到另一个点 时间=曼哈顿距离(单位分钟)

很难想到用匈牙利 (最小点覆盖=点数-最大匹配数)

时间从小到大输入的

通过计算只要时间不冲突 就代表一点到另一点就可以连通

#include<bits/stdc++.h>
using namespace std;
int match[510];
int ap[510][510];
int vis[510];
int m;
struct node
{
    int x1,x2,y1,y2;
    int t,sum;
} aa[510];

int fun(int x1,int y1,int x2,int y2)
{
    return abs(x1-x2)+abs(y1-y2);
}

int dfs(int u)
{
    int i;
    for(i=0; i<m; i++)
    {
        if(ap[u][i]==1&&!vis[i])
        {
            vis[i]=1;
            if(match[i]==-1||dfs(match[i]))
            {
                match[i]=u;
                return 1;
            }
        }
    }
    return 0;
}

int main()
{
    int i,j,c,d,sum,tt;
    char str[10];
    scanf("%d",&tt);
    while(tt--)
    {
        scanf("%d",&m);
        memset(match,-1,sizeof(match));
        memset(ap,-1,sizeof(ap));
        for(i=0; i<m; i++)
        {
            scanf("%s",str);
            scanf("%d%d%d%d",&aa[i].x1,&aa[i].y1,&aa[i].x2,&aa[i].y2);
            aa[i].t=(str[0]-'0')*10*60+(str[1]-'0')*60+(str[3]-'0')*10+(str[4]-'0');
            aa[i].sum=fun(aa[i].x1,aa[i].y1,aa[i].x2,aa[i].y2);

        }
        for(i=0; i<m-1; i++)
            for(j=i+1; j<m; j++)
            {
                if(aa[i].t+aa[i].sum+fun(aa[i].x2,aa[i].y2,aa[j].x1,aa[j].y1)<aa[j].t)
                    ap[i][j]=1;
            }
        sum=0;
        for(i=0; i<m; i++)
        {
            memset(vis,0,sizeof(vis));
            if(dfs(i)) sum++;
        }
        printf("%d\n",m-sum);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值