hdu1350Taxi Cab Scheme

Taxi Cab Scheme
Time Limit: 20000/10000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1122 Accepted Submission(s): 570

Problem Description
Running a taxi station is not all that simple. Apart from the obvious demand for a centralised coordination of the cabs in order to pick up the customers calling to get a cab as soon as possible, there is also a need to schedule all the taxi rides which have been booked in advance. Given a list of all booked taxi rides for the next day, you want to minimise the number of cabs needed to carry out all of the rides.

For the sake of simplicity, we model a city as a rectangular grid. An address in the city is denoted by two integers: the street and avenue number. The time needed to get from the address a, b to c, d by taxi is |a - c| + |b - d| minutes. A cab may carry out a booked ride if it is its first ride of the day, or if it can get to the source address of the new ride from its latest, at least one minute before the new ride’s scheduled departure. Note that some rides may end after midnight.

Input
On the first line of the input is a single positive integer N, telling the number of test scenarios to follow. Each scenario begins with a line containing an integer M, 0 < M < 500, being the number of booked taxi rides. The following M lines contain the rides. Each ride is described by a departure time on the format hh:mm (ranging from 00:00 to 23:59), two integers a b that are the coordinates of the source address and two integers c d that are the coordinates of the destination address. All coordinates are at least 0 and strictly smaller than 200. The booked rides in each scenario are sorted in order of increasing departure time.

Output
For each scenario, output one line containing the minimum number of cabs required to carry out all the booked taxi rides.

Sample Input
2
2
08:00 10 11 9 16
08:07 9 16 10 11
2
08:00 10 11 9 16
08:06 9 16 10 11

Sample Output
1
2

有向图,将时间起点终点处理成一个点,然后转为点与点链接问题
建图,二分处理,最小路径覆盖问题=定点数-最大匹配

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#define N 550
using namespace std;
struct node
{
    int time,sx,sy,tx,ty;
} cord[N];
int linkx[N],linky[N],map[N][N],vist[N];
int n;
int abs(int x)
{
    if(x<0)
        return -x;
    return x;
}
int find(int v)
{
    int i;
    for(i=1; i<=n; i++)
    {
        if(!vist[i]&&map[v][i])
        {
            vist[i]=1;
            if(linky[i]==-1||find(linky[i]))
            {
                linkx[v]=i;
                linky[i]=v;
                return 1;
            }
        }
    }
    return 0;
}
int solve()
{
    int i;
    int ans=0;
    memset(linkx,-1,sizeof(linkx));
    memset(linky,-1,sizeof(linky));
    for(i=1; i<=n; i++)
    {
        if(linkx[i]==-1)
        {
            memset(vist,0,sizeof(vist));
            ans+=find(i);
        }
    }
    return ans;
}
int main()
{
    int t;
    int i,j;
    int h,m;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=1; i<=n; i++)
        {
            scanf("%d:%d%d%d%d%d",&h,&m,&cord[i].sx,&cord[i].sy,&cord[i].tx,&cord[i].ty);
            cord[i].time=h*60+m;
        }
        memset(map,0,sizeof(map));
        for(i=1; i<=n; i++)
        {
            for(j=1; j<=n; j++)
            {
                if(i!=j&&(abs(cord[i].sx-cord[i].tx)+abs(cord[i].sy-cord[i].ty)+cord[i].time+
                          abs(cord[i].tx-cord[j].sx)+abs(cord[i].ty-cord[j].sy)<cord[j].time))
                    map[i][j]=1;
            }
        }
        cout<<n-solve()<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值