1043输出PATest

给定一个长度不超过 104 的、仅由英文字母构成的字符串。请将字符重新调整顺序,按 PATestPATest.... 这样的顺序输出,并忽略其它字符。当然,六种字符的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按 PATest 的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过 104 的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:

redlesPayBestPATTopTeePHPereatitAPPT

输出样例:

PATestPATestPTetPTePePee

编译软件:visual studio

编译语言:c语言

参考代码:

#include<cstdio>
#include<cstring>
const int maxn = 10010;

char str[maxn], dict[6] = { 'P','A','T','e','s','t' };
int hashTable[6] = { 0 };

int main()
{
    fgets(str,maxn,stdin);
    int len = strlen(str), sum = 0;
    for (int i = 0; i < len; i++)
    {
        for (int j = 0; j < 6; j++)
        {
            if (str[i] == dict[j])
            {
                hashTable[j]++;
                sum++;
            }
        }
    }
    while (sum > 0)
    {
        for (int i = 0; i < 6; i++)
        {
            if (hashTable[i] > 0)
            {
                printf("%c", dict[i]);
                hashTable[i]--;
                sum--;
            }
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值