程设之STL八选六--Set与Multiset的关系

博主本题亮点:利用set和multiset的不同之处

题目:C:Set

总时间限制: 

5000ms

内存限制: 

100000kB

描述

现有一整数集(允许有重复元素),初始为空。我们定义如下操作:
add x 把x加入集合
del x 把集合中所有与x相等的元素删除
ask x 对集合中元素x的情况询问
对每种操作,我们要求进行如下输出。
add 输出操作后集合中x的个数
del 输出操作前集合中x的个数
ask 先输出0或1表示x是否曾被加入集合(0表示不曾加入),再输出当前集合中x的个数,中间用空格格开。

输入

第一行是一个整数n,表示命令数。0<=n<=100000。
后面n行命令,如Description中所述。

输出

共n行,每行按要求输出。

样例输入

7
add 1
add 1
ask 1
ask 2
del 2
del 1
ask 1

样例输出

1
2
1 2
0 0
0
2
1 0

提示

Please use STL’s set and multiset to finish the task

本人解法:#include <iostream>
#include<set>
#include<cstring>
using namespace std;
int main()
{
    int n;
    cin >> n;
    set<int>st;
    multiset<int>st2;//利用了multiset和set的不一致性,即multiset可以存入多个相同变量
    while (n--) {
        string str;
        cin >> str;
        int j;
        cin >> j;
        if (str[1] == 'd')
        {
            st.insert(j);
            st2.insert(j);
            printf("%d\n", st2.count(j));
        }
        else if (str[0] == 'd') {
            printf("%d\n", st2.count(j));
            st2.erase(j);//只需删去st2的元素,可以规避“发过了”这一条件
        }
        else if (str[1] == 's') {
            printf("%d %d\n", st.count(j), st2.count(j));
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值