“红旗杯“第十四届东北地区大学生程序设计竞赛 Color the blocks

找规律
Color the blocks
Problem Description
Given you an N∗N grid graph,you can color any block black or white,but you have to meet the condition:

For each block (x,y),it can’t be the same color as (x−3,y),(x−1,y+2),(x+1,y+2),(x+3,y).

You need to calculate the total number of options for coloring the N∗N grid graph.

Input
There are T test cases in this problem.

The first line has one integer T(1≤T≤105).

For every test case,the first line has one integer N(1≤N≤109).

Output
For every test case, output the answer in a line.

Sample Input
2
1
6

Sample Output
2
4

Source
"红旗杯"第十四届东北地区大学生程序设计竞赛

#include<bits/stdc++.h>

using namespace std;
int main(){
    int n,t;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        if(n==1) printf("2\n");
        if(n==2) printf("16\n");
        if(n==3) printf("32\n");
        if(n>=4) printf("4\n");
    }
    return 0;
}
  • 5
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值