【Uva 401】 Palindromes

|###Description

A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string “ABCDEDCBA” is a palindrome because it is the same when the string is read from left to right as when the string is read from right to left.

A mirrored string is a string for which when each of the elements of the string is changed to its reverse (if it has a reverse) and the string is read backwards the result is the same as the original string. For example, the string “3AIAE” is a mirrored string because “A” and “I” are their own reverses, and “3” and “E” are each others’ reverses.

A mirrored palindrome is a string that meets the criteria of a regular palindrome and the criteria of a mirrored string. The string “ATOYOTA” is a mirrored palindrome because if the string is read backwards, the string is the same as the original and because if each of the characters is replaced by its reverse and the result is read backwards, the result is the same as the original string. Of course, “A”, “T”, “O”, and “Y” are all their own reverses.

A list of all valid characters and their reverses is as follows.

CharacterReverseCharacterReverseCharacterReverse
AAMMYY
BNZ5
COO11
DP2S
E3Q3E
FR4
GS25Z
HHTT6
IIUU7
JLVV88
KWW9
LJXX

Note that O (zero) and 0 (the letter) are considered the same character and therefore ONLY the letter “0” is a valid character.

Input

Input consists of strings (one per line) each of which will consist of one to twenty valid characters. There will be no invalid characters in any of the strings. Your program should read to the end of file.

Output

For each input string, you should print the string starting in column 1 immediately followed by exactly one of the following strings.

STRINGCRITERIA
” – is not a palindrome.”if the string is not a palindrome and is not a mirrored string
” – is a regular palindrome.”if the string is a palindrome and is not a mirrored string
” – is a mirrored string.”if the string is not a palindrome and is a mirrored string
” – is a mirrored palindrome.”if the string is a palindrome and is a mirrored string

Note that the output line is to include the -’s and spacing exactly as shown in the table above and demonstrated in the Sample Output below.In addition, after each output line, you must print an empty line.

Sample Input

NOTAPALINDROME
ISAPALINILAPASI
2A3MEAS
ATOYOTA

Sample Output

NOTAPALINDROME – is not a palindrome.
ISAPALINILAPASI – is a regular palindrome.
2A3MEAS – is a mirrored string.
ATOYOTA – is a mirrored palindrome.

解题思路

【palindrome】回文
【criteria】标准

LRJ紫书上的一题,书中的解法颇具技巧,这里就说下自己的理解吧。关键还是常量数组的妙用,把镜像字符存起来。读入字符串s后,则要判断是否是回文或镜像,具体细节参考注释^ ^~

参考代码

#include <stdio.h>
#include <string.h>
#include <ctype.h> //包含了判断字符的属性的一些函数
#define LEN strlen(s)
const char* rev = "A   3  HIL JM O   2TUVWXY51SE Z  8 ";//镜像字符数组,不存在的就用空格代替
const char* msg[] = {"not a palindrome", "a regular palindrome", "a mirrored string", "a mirrored palindrome"};//跟输出有关的常量数组,后面会看到方便之处!!
char r(char ch){
    return isalpha(ch)?rev[ch - 'A']:rev[ch - '0' + 25];
}//isalpha函数顾名思义,用来判断一个字符是否为字母,r函数用来返回字符ch的镜像
int main()
{
    char s[30];
    while (scanf("%s",s)==1){
        int p = 1,m = 1,i;
        for (i = 0;i < (LEN+1)/2;i++){ // 注意循环到 (LEN+1)/2
            if (s[i] != s[LEN-1-i]) // 回文判断,len-1为字符串最后一个元素的下标,len-1-i即是与i从后往前对应的下标
                p = 0;
            if (r(s[i])!= s[LEN-1-i]) // 镜像判断
                m = 0;
        }
        printf("%s -- is %s.\n\n",s,msg[2*m+p]);// 2*m+p这个技巧性好强,渣渣的我是想不到啦┑( ̄Д  ̄)┍
    }
    return 0;
} 
mp2*m+p对应状态
000not a palindrome
011a regular palindrome
102a mirrored string
113a mirrored palindrome
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值