组队选拔赛01 ---- volim

Problem Description

Croatia’s national television programme is broadcasting an entertainment show titled “I Love Croatia”,modeled on the licensed format I love my country. In this show two teams of celebrities and public figures play various games which require knowledge about Croatia. One of the games is Happy Birthday, which will be used in this task, although somewhat altered.

这里写图片描述

Eight players numbered one through eight are seated in a circle (see picture). One of them is holding a box which will explode after 3 minutes and 30 seconds from the beginning of the game when some colorful confetti will be blown out. The game begins with a question to the player holding the box. If the players answers incorrectly or skips the question, he is immediately given the next question. If the player answers correctly, he passes the box to the first player seated on his left and then that player gets the next question.

You are given the numbered label of the player who has the box in the beginning and the outcomes of the first N questions asked. Determine the numbered label of the player who had the box when it finally exploded. The question outcome is described with the following data - time passed from the beginning of the question being asked to the moment an answer was given and whether the answer was true (“T”), false (“N”) or skipped (“P”). The time between giving the answer and asking the next question shouldn’t be taken into consideration, as well as time necessary for the box to be passed to the next player. The box will surely explode on a player’s turn.

Input

There are multiple test cases. Please process till EOF.The first line of input contains a positive integer K (1 ≤ K ≤ 8), the numbered label of the player who has the box initially.

The second line of input contains a positive integer N (1 ≤ N ≤ 100), the number of questions askedduring the game.

Each of the following N lines contains a positive integer T (1 ≤ T ≤ 100), time passed from thebeginning of the i-th question being asked to the moment an answer was given, measured in seconds,and a single character Z (‘T’, ‘N’ or ‘P’), the type of answer given.

Output

The first and only line of output must contain the numbered label of the player who had the box when it finally exploded.

Sample Input

1
5
20 T
50 T
80 T
50 T
30 T
3
5
100 T
100 N
100 T
100 T
100 N
5
6
70 T
50 P
30 N
50 T
30 P
80 T

Sample Output

5
4
7

解题思路

题意是 8个人参加比赛,给出起始的人,然后每个人回答问题, 给出做出抉择的时间,以及抉择类型(答对(T),答错(N),跳过(P)).答对就换左边的人,答错或跳过那么当前的人继续答题,问经过3分30秒后,停在哪个人.

直接按输入模拟即可!

参考代码

#include <stdio.h>
int main()
{
    int n, k, num[8];
    char s[3];
    while (~scanf("%d %d",&k,&n)){
        int cur = 0, t;
        for (int i = 0;i < n;i++){
            scanf("%d %s",&t,s);
            cur += t;
            if (cur >= 210){
                printf("%d\n",(k-1)%8+1);
                cur = 0;
            }
            if (s[0] == 'T') k++;       
        }       
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值