F - Drying(思维+二分)

Drying

Time limit 1000 ms Memory limit 32768 kB OS Windows


Problem Description

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input

sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5

Sample Output

sample output #1
3

sample output #2
2


题意:

现在有n件衣服,上面有ai个单位水,衣服可以通过两种方式变干,一种是自然风干,每分钟减少1单位水,另一种是用吹风机吹干,每分钟减少k单位水。吹风机每分钟只能吹一件衣服,给出可以使用吹风机的时间,问能让所有衣服都变干的最短时间。

解题思路:

做这个题目一开始就陷入了误区,以为每件衣服必须要一次吹干。但实际上我们可以拿这件衣服吹一分钟,就算还没吹干我们也可以把它放到一边让它自然风干,然后吹另一件衣服。
解法是对时间进行二分,如果可以在t时间风干,那就继续找更小的,否则找更大的。
难点就在于怎么判断是否可以在t时间内风干。
首先对于Ai小于t的衣服,可以直接自然风干,不需要吹风机,所以不用考虑。我们假设第i件衣服需要 X 分钟吹风机的时间,Y分钟自然风干的时间,已知总时间 t ,衣服的水量Ai , 吹风机每分钟减少k单位水, 自然风干每分钟减少1单位水。有:

X + Y = t
X * k + Y >= Ai

由这两个式子可得:X>=(Ai-t)/(k-1)
有了这个式子就可以计算出所有衣服需要使用吹风机的最小时间,把这些时间相加,如果这个时间小于t就说明可以在t时间内吹干所有衣服。

后来又因为没用long long导致WA,现在还不清楚原因。


Code:

#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
typedef long long LL;
const int maxn=100000+4;

LL a[maxn];
LL mmax,N,k;

bool f(LL t)
{
    LL cnt=0;
    for(int i=0;i<N;i++)
    {
        if(a[i]>t)
        {
            cnt+=(a[i]-t)/(k-1);
            if((a[i]-t)%(k-1))//向上取整
                cnt++;
        }
    }
    if(cnt<=t)
        return true;
    return false;
}

LL bs()
{
    LL lo=1,hi=mmax;
    LL ans;
    while(lo<=hi)
    {
        LL mid=((hi-lo)>>1)+lo;
        if(f(mid))//如果可以在t内吹干所有衣服
        {
            ans=mid;
            hi=mid-1;
        }
        else
            lo=mid+1;
    }
    return ans;
}


int main()
{

    while(scanf("%I64d",&N)!=EOF)
    {
        mmax=0;
        for(int i=0;i<N;i++)
        {
            scanf("%I64d",a+i);
            if(mmax<a[i])
                mmax=a[i];
        }
        scanf("%d",&k);
        if(k==1)//k等于1的情况就相当于没有吹风机,所有衣服都只能自然风干
        {
            cout<<mmax<<endl;
            continue;
        }
        LL ans=bs();
        cout<<ans<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值