It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.
Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.
There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.
Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).
The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.
<b>sample input #1</b> 3 2 3 9 5 <b>sample input #2</b> 3 2 3 6 5
<b>sample output #1</b> 3 <b>sample output #2</b> 2
1、水量<=mid的衣服,直接晾干就可以了,不需要浪费烘干机。
2、水量>mid的衣服,有两部分时间:x 用烘干机的时间,那么用烘掉的水量就是x*k;y 风干的时间。且mid=x+y。
那么还有一个式子:p[i] <= x*k + y;联立解得 x>=(p[i] - mid)/(k-1)。
#if 0
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <iostream>
#include <algorithm>
using namespace std;
int a[100010],k,n;
int fun(int mid)
{
int sum=0;
for(int i=0; i<n; i++)
{
if(a[i]<=mid)
{
continue;
}
else
{
sum+=ceil((double)(a[i]-mid)/(k-1));
}
if(sum>mid)
{
return 0;
}
}
return sum<=mid;
}
int main()
{
cin>>n;
int l=0,r=0,mid=0,maxx=0;
for(int i=0; i<n; i++)
{
scanf("%d",&a[i]);
maxx=max(maxx,a[i]);
}
scanf("%d",&k);
if(k==1)
{
printf("%d\n",maxx);
}
else
{
r=maxx;
while(r>=l)
{
mid=(r+l)/2;
if(fun(mid)) //shao
{
r=mid-1;
}
else
{
l=mid+1;
}
}
printf("%d\n",l);
}
}
#endif