POJ 1915:Knight Moves(BFS)

Knight Moves

Time limit:1000 ms Memory limit:30000 kB OS:Linux


Problem Description

Background
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him?
The Problem
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov.
For people not familiar with chess, the possible knight moves are shown in Figure 1.


这里写图片描述

Input

The input begins with the number n of scenarios on a single line by itself.
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, …, l-1}*{0, …, l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.

Output

For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.

Sample Input

3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1

Sample Output

5
28
0


题意:

国际象棋中,马只能走日(看图),给出初始位置和目标位置,求最少步数。

解题思路:

这么水的。。直接BFS就好了,注意一下清空队列


Code:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;

const int maxn=300+5;
int vis[maxn][maxn];
int n;
int dx[]={-2,-1,1,2,2,1,-1,-2};
int dy[]={1,2,2,1,-1,-2,-2,-1};

struct Node
{
    int x,y,step;
};
queue<Node> Q;

bool check(int x,int y)
{
    if(x<0||x>=n||y<0||y>=n)
        return false;
    if(vis[x][y])
        return false;
    return true;
}

int BFS(int x1,int y1,int x2,int y2)
{
    while(!Q.empty())
        Q.pop();

    vis[x1][y1]=1;
    Q.push((Node){x1,y1,0});
    while(!Q.empty())
    {
        Node u=Q.front();
        //cout<<u.x<<' '<<u.y<<' '<<u.step<<endl;
        Q.pop();
        if(u.x==x2&&u.y==y2)
            return u.step;

        for(int i=0;i<8;i++)
        {
            int x=u.x+dx[i];
            int y=u.y+dy[i];
            if(check(x,y))
            {
                vis[x][y]=1;
                Q.push(Node{x,y,u.step+1});
            }
        }
    }
    return 0;//这句不能少
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int x1,y1,x2,y2;
        scanf("%d%d%d%d%d",&n,&x1,&y1,&x2,&y2);
        mem(vis,0);
        int ans=BFS(x1,y1,x2,y2);
        printf("%d\n",ans);
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值