1115 Counting Nodes in a Binary Search Tree 甲级 xp_xht123

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than or equal to the node's key.
  • The right subtree of a node contains only nodes with keys greater than the node's key.
  • Both the left and right subtrees must also be binary search trees.

Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000) which is the size of the input sequence. Then given in the next line are the N integers in [−1000,1000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:

10
25 30 42 16 20 20 35 -5 28 22

Sample Output:

3 + 4 = 7

解题思路:首先注意定义,二叉搜索树的定义,不同于其他的二叉搜索树的题就是左子树是小于等于根节点的,其次使用递归进行建树和遍历操作,得到最深的层数和每一层的节点数,最后输出最后两层的节点个数和节点总数

以下是代码:

insert操作

//将无用的节点置成0
//节点从0开始
void insert(int &u , int x)
{
    if(!u)
    {
        u = idx ++;
        v[u].val = x;
    }
    else if(x <= v[u].val) insert(v[u].left , x);
    else insert(v[u].right , x);
}

或者将所有节点置成-1使用memset函数

dfs

int max_depth = 0;
int cnt[N] = {0};

void dfs(int u , int depth)
{
    if(!u) return ;
    cnt[depth] ++;
    max_depth = max(max_depth , depth);
    dfs(v[u].left , depth + 1);
    dfs(v[u].right , depth + 1);
}

完整代码:

//注意该题不同于其他二叉搜索树的是左子树是
//小于等于根的 而不是 小于
#include<iostream>

using namespace std;
const int N = 1010;

struct Node
{
    int left;
    int right;
    int val;
}v[N];

int n;
int idx = 1;
//将无用的节点置成0
void insert(int &u , int x)
{
    if(!u)
    {
        u = idx ++;
        v[u].val = x;
    }
    else if(x <= v[u].val) insert(v[u].left , x);
    else insert(v[u].right , x);
}

int max_depth = 0;
int cnt[N] = {0};

void dfs(int u , int depth)
{
    if(!u) return ;
    cnt[depth] ++;
    max_depth = max(max_depth , depth);
    dfs(v[u].left , depth + 1);
    dfs(v[u].right , depth + 1);
}

int main()
{
    cin>>n;
    int root = 0;
    for(int i = 0;i < n;i ++)
    {
        int num;
        cin>>num;
        insert(root , num);
    }
    
    dfs(root , 0);
    
    printf("%d + %d = %d" , cnt[max_depth] , cnt[max_depth - 1] , cnt[max_depth] + cnt[max_depth - 1]);
    return 0;
}

Counting Supports of Candidates Using Hash Tree”是一种利用哈希树来计算候选项集支持度的方法。以下是一个简单的例子,说明如何使用哈希树来计算候选项集的支持度。 假设我们有一个包含以下事务的数据集: ``` t1: {1, 2, 3, 4} t2: {1, 2, 4, 5} t3: {2, 4, 5} t4: {1, 2, 3, 4, 5} ``` 我们要计算每个2项集的支持度。首先,我们需要生成所有的2项集: ``` {1, 2} {1, 3} {1, 4} {1, 5} {2, 3} {2, 4} {2, 5} {3, 4} {3, 5} {4, 5} ``` 接下来,我们可以使用哈希树来计算每个2项集的支持度。首先,对于每个项集,我们将其插入到哈希树中。具体地,从根节点开始,对于每个项集中的元素,根据哈希函数计算其子节点的位置,并将项集插入到相应的节点中。例如,对于项集{1, 2},我们需要依次插入到根节点、子节点1和子节点2中。最终,我们得到以下哈希树: ``` {} / | | \ 1 2 3 4 /| | | \ 2 3 4 5 5 / | | | 3 4 5 4 ``` 在计算支持度时,我们只需要遍历哈希树的叶子节点,找到包含在每个事务中的项集,并增加其计数器的值。例如,当处理事务t1时,我们需要遍历项集{1, 2}、{1, 3}、{1, 4}和{2, 3},并增加其计数器的值。最终,我们得到每个2项集的支持度: ``` {1, 2}: 3 {1, 3}: 1 {1, 4}: 2 {1, 5}: 1 {2, 3}: 2 {2, 4}: 3 {2, 5}: 2 {3, 4}: 2 {3, 5}: 2 {4, 5}: 2 ``` 这就是使用哈希树来计算候选项集支持度的简单示例。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值