「1115」Counting Nodes in a Binary Search Tree

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than or equal to the node’s key.
  • The right subtree of a node contains only nodes with keys greater than the node’s key.
  • Both the left and right subtrees must also be binary search trees.

Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000) which is the size of the input sequence. Then given in the next line are the N integers in [−1000,1000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:

10
25 30 42 16 20 20 35 -5 28 22

Sample Output:

3 + 4 = 7

Ω

按照给定数组构建二叉搜索树,然后输出最低两层节点个数,以及两者之和。

不是很难,由于数组中的值并不是两两不同的,因此不能直接用值当索引去查找子节点。直接在构建BST的过程中,一边插入一边计数深度,最后将相应深度的节点个数+1,最后输出最大两个深度的节点个数即可。


🐎

#include <iostream>
#include <vector>
#include <map>

using namespace std;

int main()
{
    int n, root = 0;
    cin >> n;
    map<int, int, greater<>> cnt{{1, 1}};
    vector<pair<int, int>> sons(n, {-1, -1});
    vector<int> value(n);
    cin >> value[0];
    for (int i = 1; i < n; ++i)
    {
        int depth = 0, *tmp = &root;
        cin >> value[i];
        while (++depth, *tmp != -1)
            tmp = value[i] > value[*tmp] ? &(sons[*tmp].second) : &(sons[*tmp].first);
        *tmp = i, cnt[depth] += 1;
    }
    int a = cnt.begin()->second, b = ++cnt.begin() == cnt.end() ? 0 : (++cnt.begin())->second;
    printf("%d + %d = %d", a, b, a + b);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值