1107 Social Clusters 甲级 xp_xht123

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

Ki​: hi​[1] hi​[2] ... hi​[Ki​]

where Ki​ (>0) is the number of hobbies, and hi​[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

解题思路:经典的并查集问题,题目描述的每一行都代表一个人所有的爱好,因此存数据的时候对于一个爱好存它拥有的所有的人,然后对于一个爱好中的人,取一个集合中的两个人,先看一下是否在一个集合中,如果是就不管了,如果不是将后者加入到前者的集合中,最后遍历了一遍得到总共的集群的个数和每一个集群的个数输出即可

#include<iostream>
#include<vector>
#include<algorithm>

using namespace std;
const int N = 1010;
int n;
vector<int>hobby[N];
int p[N];
int res[N];

bool cmp(int a , int b)
{
    return a > b;
}

int find(int x)
{
    if(p[x] != x) p[x] = find(p[x]);
    return p[x];
}

int main()
{
    cin >> n;
    for(int i = 1;i <= n;i ++) p[i] = i;
    
    for(int i = 1;i <= n;i ++)
    {
        int k;
        scanf("%d:", &k);
        for(int j = 0;j < k;j ++)
        {
            int num;
            cin >> num;
            hobby[num].push_back(i);
        }
    }
    
    for(int i = 1;i < N;i ++)
    {
        for(int j = 1;j < hobby[i].size();j ++)
        {
            //并查集一般写法
            //把后一个加到前一个去
            int a = hobby[i][j - 1] , b = hobby[i][j];
            a = find(a) , b = find(b);
            
            if(a != b) p[b] = a;
        }
    }
    
    int si = 0;
    for(int i = 1;i <= n;i ++) res[find(i)] ++;//记录每一个群的人数
    
    for(int i = 1;i <= n;i ++) if(res[i]) si ++;
    
    sort(res , res + n + 1 , cmp);
    
    cout << si << endl;
    cout << res[0];
    for(int i = 1;i < si;i ++) cout << " " << res[i];
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值